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FOREWORD 
Thank you for purchasing the model VG-862 video signal generator. 
This manual provides details on how to use the SP-8022-2 software program as an application of the 
VG-862 and the precautions to be heeded when doing so.  
Since improper handling may lead to accidents, we recommend that you take the time to read through 
this manual without fail before attempting to operate the VG-862: the information provided will 
ensure that you will operate the VG-862 properly.  
After reading through this manual, keep it in a safe place for future reference.  
 
 

SAFETY PRECAUTIONS 

 
Concerning foreign matter 

• Do not spill liquids onto the product or drop inflammable objects or metal parts onto it. Use 
under these conditions may cause a fire, electrical shock or malfunctioning.  

 
 
 
 

Concerning the installation and operating locations 

• Install this product in a stable place. (Standing the product on its side and operating it will 
cause its temperature to rise due to heat generation and this may invite malfunctioning.)  

 

Concerning impact 
• This is a precision piece of equipment and, as such, subjecting it to impact may cause 

malfunctioning. Take special care when moving the product. 
 

WARNING

CAUTION
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CHAPTER 1 
CONCERNING THE SP-8022-2 

1.1 General 
The SP-8022-2 is an application software program for operating the VG-862, and it is 
designed to be run in Windows 98/2000/XP. It enables the statuses of the VG-862 to be 
captured and its settings to be changed. It can also generate data and execute the data 
generated.  
All operations are conducted at the personal computer, and the generated data can be stored as 
files. 
* With Windows 98, more than one VG board (VG-860, VG-861 and/or VG-862) 

cannot be installed and used at the same time. 

* With Windows 2000, both the VG-861 and VG-862 boards can be installed and used 
at the same time. 

 
1.2 Features 

(1) Software program compatible with Windows 98/2000/XP 
This program enables data to be edited in Windows 98/2000 and signals to be output. The 
pattern data editing functions enable the execution of pattern preparation functions which 
use the GUI and have a much greater degree of freedom than in the past, and they enable 
JPEG/BMP and other natural images (in full color) to be displayed. 

 
(2) Simple data control functions with a higher degree of freedom 

Timing data and pattern data can be organized separately in their own files. Control over 
this data can easily be exercised by such features as the list display, sort function and 
naming function. 

 
(3) Sample data 

Different kinds of data are copied as sample data when the program is installed, and this 
data can be combined as desired and the resulting signals can be output. The sample data 
copy function can be used when data is to be edited. 

 
1.3 Installing the software (Windows 98/2000/XP) 

Described here is the method used to install the files for running SP-8022-2 in Windows 98 or 
Windows 2000. 

This description supplements what is provided on the following disk. 

Windows 98/2000 version SP-8022-2 installation CD 
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1.3.1 Installing the drivers 

The first step is to install the drivers. 
(1) When the VG-862 is to operated for the first time 

• When Windows 98/2000 is used 

1) After Windows has started up, the system recognizes the VG-862, and 
the "Add New Hardware" dialog box appears. Follow the on-screen 
instructions, and press [Next]. 

2) The "Install Hardware Device Driver" dialog box is now opened.  
Check "Search the optimum driver for device," and press [Next]. 

3) The "Specify Driver File" dialog box is now opened. Insert the 
SP-8022-2 installation CD into the drive, check "CD-ROM drive" or 
“Designate the place,” then select the driver file in the folder of “98” or 
“2000”, and press [Next]. 

4) Upon completion of the installation, the system restart confirmation 
dialog box appears. Select [Yes] to restart the system. 

• When Windows XP is used 

1) After Windows has started up, the system recognizes the VG-862, and 
the "Add New Hardware" dialog box appears. Follow the on-screen 
instructions, and press [Next]. 

2) The "Install Hardware Device Driver" dialog box is now opened. Check 
"Search the optimum driver for device," and press [Next]. 

3) The "Specify Driver File" dialog box is now opened. Insert the 
SP-8022-2 installation CD into the drive, check "CD-ROM drive" or 
“Designate the place,” then select the driver file in the folder of “XP,” 
and press [Next]. 

4) Install SP-8022-2 searching the driver.  The below dialog appears 
asking the Microsoft certification, select “continue.” 

 

 
5) Upon completion of the installation, the system restart confirmation 

dialog box appears. Select [Yes] to restart the system. 
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* Plug & play is supported for the PCI bus devices in Windows 2000 as a 
standard feature. However, since the drivers in this library are not plug & 
play compatible, the steps described above which are non-standard steps 
must be taken.  

Furthermore, these drivers are not recognized by Windows 2000 as standard 
devices. 

The drivers are registered as problematic devices by the System Information 
tool which is accessed by selecting Accessories from the Program menu 
followed by System Tools, but this does not impede operation in any way. 

* Since, when Windows 2000 is used, SP-8022-2 is installed along with the 
drivers at this point, ignore the instructions given in section "1.3.2 Installing 
the SP-8022-2" which follows. 
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1.3.2 Installing the SP-8022-2  

Next, install the SP-8022-2 application software. 
(1) Insert the SP-8022-2 installation CD into the CD drive, and in Windows select 

[Start] - [Settings] - [Control Panel] - [Add/Remove Programs] - [Install...]. The 
installer now starts up, and setup commences. 

 
(2) First, the "Welcome" dialog box 

appears. If the [Next] button is 
clicked, setup advances to the 
next step; if the [Back] button is 
clicked, it returns to the previous 
step. Press  the [Cancel] button 
to abort the setup.  
Click the [Next] button. 

 
 
 
(3) Select the copy destination 

directory on the "Select 
Installation Destination" dialog 
box. As the default, a directory 
known as "ASTRO\SP-8022-2" 
is created in the root directory of 
drive C, and the files are copied 
into this directory. The copy 
destination directory can be 
changed to the one designated 
by the user at this point. Click 
[Browse], and set the directory. 

 
 
(4) Select the [Next] button. The 

"Start Copying Files" dialog 
box appears. File copying 
starts when the [Next] button is 
selected. 
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(5) This completes the setup. 
Restart the computer. 

 
 
 
 
 
 
 
 
 
 
 (6) The dialog for restart appears    
after pressing “complete.”   
Restart the computer here. 
 
 
 

 
(7) After the computer has been restarted, the SP_8022.bat file is run only once, and 

the files inside the SampleData directory are changed to read-only properties. 
(8) The installation is now completed. In Windows, select [Start] - [Programs] - 

[SP-8022-2] - [Guide Help], and read the information given. Then select [Start] - 
[Programs] - [SP-8022-2] - [Sequence Editor], and start [Sequence Editor]. 

 
1.3.3 How to uninstall SP-8022-2 

In Windows 98 or 2000, select [Start] - [Settings] - [Control Panel] - [Add/Remove 
Programs], and select and delete SP-8022-2. 
To reinstall SP-8022-2, first delete the files and registry settings by following the 
uninstallation procedure, and then proceed with the reinstallation. If any of the 
previous files are left, the SP-8022-2 may not operate properly. (It is no problem even 
there remains data file in the SampleData directry.) 
The data files in the SampleData directory are read-only files and, as such, they will 
not be deleted by uninstallation. Delete them separately. Neither will the drivers be 
deleted by uninstallation so delete them separately as well. 
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CHAPTER 2 
CONCERNING THE DATA 

 
2.1 Concerning the data of the SP-8022-2 

The sample data is copied when the SP-8022 program is installed.  
This data can be used as the source data for execution, editing or copying.  
Data can be executed or edited after copying this data.  

 
2.2 Data configuration 

The SP controls the data to be executed by the VG in the form of sequence data.  
Sequence data consists of combinations of the timing data, pattern data, palette set data, action 
data and interval data. All the data (that is to say, the timing data, pattern data, palette set data 
and action data) except for the interval data is controlled in separate files.  
Sequence data is created by specifying which files are to be used.  
 

Sequence data 

This data consists, of combinations of the timing data, pattern data, 
palette set data, action data and interval data. 
Offset (X, Y) and size (H, V) are added to the pattern data as additional 
information. 
The interval data (number of seconds during the auto execution of the 
sequence data) is controlled as part of the sequence data. When the 
sequence data is executed, the timing data, pattern data, palette set 
data, action data are sent to the VG and time monitoring is performed. 
The sequence data is created by the sequence editor.  
In the PC, the sequence data is controlled in the form of sequence files.

Timing data 
This data defines the H/V timing and output conditions. 
It is created by the timing editor. 
In the PC, it is controlled in the form of timing data files. 

Pattern data 

There are three types of pattern data: graphic patterns, bitmap patterns 
and optional patterns which are created by the graphic pattern editor, 
image converter and optional pattern editor, respectively. 
In the PC, it is controlled in the form of pattern data files. 

Palette set data 

This data defines the LUT data of the 256+1 colors among 16.7 million 
colors.  
It is created by the palette set editor. 
In the PC, it is controlled in the form of palette set data files. 

Action data 

This data defines the flickering of the designated palette number, auto 
scrolling of the palettes and other such operations.  
It is created by the action editor.  
In the PC, it is controlled in the form of action data files. 
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CHAPTER 3   
SP-8022-2 PROGRAM CONFIGURATION AND OPERATION 

3.1 SP-8022-2 program configuration 
The SP-8022-2 consists of a program which edits the sequence data and programs which edit 
the data registered in the sequence data. (See section 2-2 for further details on the data.) 
The sequence editor is the main program of the SP-8022-2. It edits the sequence data and 
executes the VG operations. The other data editing programs are started from the sequence 
editor.  

 
3.2 Names of screen parts common to all windows 
 

Fig. 3-1 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Title bar 
The name of the currently open sequence file appears here.  

Menu bar 
The menu appears here. 

Tool bar 
This contains the buttons which correspond to the commands used relatively frequently to 
enable one of these commands to be started up at the push of a button.  

Comment edit box 
Comments for files can be input here. 

 

Tool bar

Menu bar

Comment edit 
box 

Title bar
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Fig. 3-2 
 
 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Drive box 
The drive is designated here.  
Select the drive from the drop-down list. 

Directory box 
The directory is selected here. 

File list box 
The files (which are displayed without their extensions) are selected here.  

File edit box 
The files (which are displayed without their extensions) are input here.  

Comment edit box 
The comment appears here. (No editing is possible.)  

New comment edit box 
The comment of the selected file is displayed here. (No editing is possible.) 

 
 

Comment 
edit box

File list box

Directory 
box 

File edit box 

New comment edit 
box 

Drive box
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CHAPTER 4 
OPERATING PROCEDURES FOR EACH PROGRAM  

The SP-8022-2 comes with the following data editing programs. 
1. Sequence editor 
2. Timing editor 
3. Graphic editor 
4. Optional pattern editor 
5. Image converter 
6. Palette set editor 
7. Action editor 
8. Execution program used for manufacture 

 
 
4.1 Sequence editor  

This section describes, how to set the sequence editor which is run by the programmable video signal 
generator (hereafter abbreviated to "VG"). Using the sequence editor in Windows, how to register 
data in the VG and execute it by means of this program will also be described.  
 
4.1.1 Startup method  

When the program is started up, the sequence file opened last when the program was  
previously started up appears, and the execution mode is established.  
However, it will start up with nothing displayed when the program is started up for the first 
time after installation or if "Open sequence file at startup" has been set to off for the 
environment setting.  
The output condition dialog box also appears but only if this dialog box was displayed when 
the program was previously started up. 
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4.1.2 Window screen and names  
 
Fig. 4-1 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 
 

Sequence list  
This is the area where the sequence data is prepared.  
Combinations of sequential numbers, timing names, pattern names, palette set names, action 
names and intervals make up the sequence data. 
When No. is selected, selection is performed in line increments; otherwise, selection is performed 
in cel1 increments.  
When the mouse's left button is clicked while holding down the shift key, the cells from the 
original cursor position to the position clicked by the mouse can be selected in one go.  
When the mouse's right button is clicked on the sequence list, the menu is opened. The menu items 
differ according to the selected cells.  
 

Status area  
This area is for displaying details of the cells selected by the sequence list. Nothing is displayed 
when more than one cell has been selected by the sequence list. 

 

Tool bar 

Sequence execution 
buttons 

Source list 

Sequence list 

Automatic maximum 
sequential No. 
change button 

Timing button, Pattern button, Paｌette Set button, Action button, Trash button 

Mode change buttons Maximum sequential No.

Status area 
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Source list  

The source files which can be registered on the sequence list are displayed in this area.  
The display is switched between different types of source files by pressing one of buttons at the 
left end.  

 

Timing button  A list of the timing data files (with extension .tim) in the "Timing" 
directory is displayed. 

Pattern button  A list of the pattern data files (with extension .gpc, .vbm or .mo) in 
the "Pattern" directory is displayed. 

Palette Set button  A list of the palette set data files (with extension .pal) in the 
"PalSet" directory is displayed. 

Action button  A list of the action data files (with extension .act) in the "Action" 
directory is displayed. 

Trash button  

A list of all the files in the "Trash" directory (trash box directory) is 
displayed. The "Trash" directory is automatically created at the 
bottom level of the directory in which SP is installed, and it cannot 
be changed. All the deleted source files are deposited in the trash 
box. Any of the source files which have once been deleted and 
which are now in the trash box can be revived by moving them to a 
source directory. When source files are deleted in the trash box, 
they are deleted for good and cannot be revived.  

 
When the left mouse button is clicked while the Shift key is held down, all the lines from the 
original cursor position to the position clicked by the mouse can be selected altogether.  
Sorting can be initiated by pressing the respective column headers on the list. When the right 
mouse button is clicked on the source list, the menu is opened. 

 
Mode change buttons  

These buttons are used to switch between the Execute mode and Edit mode.  
In the Execute mode, execution alone is possible; in the Edit mode, both editing and execution are 
possible.  

 
Maximum sequential No.  

The maximum sequential No. registered on the sequence list is displayed and changed in this area. 
When this value is changed, the number of sequence list lines changes. 

 
Automatic maximum sequential No. change button  

This is used to delete the unregistered lines from the end of the lines registered on the sequence list. 
Processing is ended where the registration location was found. 

 
Execution data type check box  

The type of data to be executed here when an execution button pressed is checked. This check box 
is valid only when one of the execution buttons has been pressed.  

 
Execution buttons  

These buttons are used to execute the type of data which has been checked in the execution data 
type check box.  
Execution commences from the sequential No. selected on the sequence list (hereafter referred to 
as the "current sequential No.").  
Multiple numbers selected on the sequence list will be ignored. In this case, execution will start 
from the highest No. selected.  
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Auto Exec button ------ Auto execution  
This is used to execute the current sequential No. after which there is a wait for the number of 
seconds in each interval  
After this, the current sequence No. is incremented by I and that sequence No. is executed after 
which there is a wait for the number of seconds in each interval.  
When the Repeat check box has been checked, execution returns to No.1 after the final No. 
This is repeated until the button is pressed again. 
If the box has not been checked, auto execution is ended as soon as the last No. is executed.  

 
Prev Step button ------- Manual execution  

This steps the current sequential No. back to the previous No. and executes it. 
 
Next Step button ------- Manual execution  

This steps the current sequential No. forward to the next No. and executes it. 
 
Execute button ------ Manual execution 

This executes the current sequential No.  
 
4.1.3 Menus 

(1) [File] menu 
Menu command Function 

New Sequence  Creates a new sequence list. 
Open Sequence  Opens the sequence file. 
Reopen Sequence  Opens the sequence file already created. 

Save Sequence  Saves the sequence in the sequence file while overwriting 
the existing sequence in that file. 

Save Sequence As Changes the sequence filename and saves the sequence in 
that file. 

Close Sequence  Ends the sequence file editing. 
Properties  Displays the sequence file properties. 
Print  Prints the display data. 
Exit SP-8022-2  Exits the program. 

 
(2) [View] menu  

This is used to change the display mode of the sequence editor. 
 

Menu command Function 
Source  Displays the source list when Source is selected. 
Output Control  Sets the output conditions  
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(3) [Sequence] menu 

This is used to register the source files on the sequence list. 
 
Menu command Function 

Execute  Executes the cells selected on the sequence list. 
Undo  Undoes the last operation. 

Select  Selects the file to be registered on the sequence list from 
the selection dialog box. 

Edit  Starts the editor which will edit the source files registered 
in the selected cells. 

Clear  Clears the data in the selected cell range. Data can be 
undone. 

Copy  Copies the selected cell range. 
Cut  Cuts out the selected cell range on the clipboard. 
Paste  Pastes the selected cell range from the clipboard. 
All Select  Selects all the cell data on the sequence list. 

Insert-U  Adds the cell (or line) immediately above the selected cell 
(or line). 

Insert-Down  Adds the cell (or line) immediately below the selected cell 
(or line). 

Delete  Deletes the selected cell (or line) and carries the data 
forward. Deleted data cannot be undone. 

Find  Initiates a search. 
Replace  Initiates replacement. 
Find from Source  Finds the registered source file from the source list. 
Change Pattern Offset/ 
Size  Changes the pattern offset/size. 

Toggle Action/  
No Action  

Sets "No action" in a blank cell. The setting of the "No 
action" cell is released, and the cell becomes blank. 

 
(4) [Source] menu 

This is used to create source files for registration on the sequence list.  
Menu command Function 

Execute Executes the source file selected from the source list. 
Update All Source Reconstructs the source list. 
All Select Selects all the files on the source list. 
New Creates a new source file. 
Edit Edits a source file. 
Copy As Copies a source file. 
Rename As Renames a source file. 
Delete Deletes the selected source file. 
Find Searches a source file from the source list. 
Find from Sequence Searches a source file from the sequence list. 
Revive from Trash Revives the source file in the trash box. 
Empty Trash Empties the trash box.  
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(5) [Internal] menu  

User characters and font sets can be registered in the board VG.  
Graphic patterns and optional patterns are referenced for the user characters and font 
sets which have been registered.  
Since the execution mode is established immediately after startup, change to the editing 
mode. When new creation has been selected, the editing mode is selected automatically.  
 

Menu command Function 
User Character Editor The character editor starts up. 
Font Set Editor The font editor starts up. 

 
(6) [Tools] menu  

This is used to adjust the sequence editor environment.  
 

Menu command Function 
Environment 
Options Establishes the environment settings. 

Error Check Checks for errors on the sequence list which has been created.
Import Source Enables source files to be imported from other directories. 
Export Source Enables source files to be exported to other directories. 
Find Source from 
Other Sequence 

Finds out whether the source file is being used by another 
sequence file. 

 
(7) [Help] menu  

Menu command Function 
Contents Displays the help contents. 
About Displays the version information.  

 
4.1.4 Startup 

When the program is started up, the sequence file opened last when the program was 
previously started up appears, and the execution mode is established.  
However, it will start up with nothing displayed when the program is started up for the first 
time after installation or if "Open sequence file at startup" has been set to off for the 
environment setting.  
The output condition dialog box appears only if this dialog box was displayed when the 
program was previously started up. 
 
(1) Startup for the first time after installation  

1) Select the [New Sequence] menu item on the [File] menu.  
Input the name of the sequence to be created and the directory name.  

 
Fig. 4-2 

 
[Sequence Name] 

Input the name of the sequence to be created.  
This name will serve as the sequence filename (extension .seq).  
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Wild cards cannot be used. 
[Directory] 

Input the name of the directory where the sequence data is to be created.  
If a nonexistent directory is designated, the directory is created automatically. 
Wild cards cannot be used. 

 
It is now assumed that, as shown in the figure, NewSeq has been input as the 
sequence name and C:\VG as the directory name. 
 
When the OK button is pressed, the C:\VG directory is created under which the 
timing, pattern, palette set and action directories (collectively referred to henceforth 
as the "source directories") are created.  
 
The data files are stored in these source directories. 

 
2) Select where to copy the source files from.  

The files in the source directory at the bottom layer are referenced for the sequence 
files created in the C:\VG directory.  
 

Timing files are stored in the Timing directory among the source directories.  
Similarly, pattern files are stored in the Pattern directory, palette set files in the 
Palette Set directory, and action files in the Action directory.  
Therefore, sequence files cannot be created unless sources files exist in the 
source directory.  

 
Fig. 4-3  
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When a new sequence file is created in a new directory, no source files exist in 
the source directory. In a first-time case, it is recommended that source files be 
copied from the sample files.  
Source files can also be copied and brought by selecting [Import Source] on the 
[Tools] menu at a later time.  
When the OK button is pressed, the designated source files are copied into the 
source directory. This completes the preparations for editing the sequence list. 

 
(2) Startup for the second and subsequent times after installation  

Open the sequence file.  
When a new file is to be created, follow the same procedure as that described in 
"Startup for the first time after installation."  
However, a source file will not be copied when a new file is created in a directory 
where the sequence file has already been created. To copy a source file, select the 
[Import Source] menu item on the [Tools] menu at a later time.  
Create the source file and register it on the sequence list as needed. The execution 
mode is established immediately after startup. To perform editing, switch to the 
editing mode. 

 
4.1.5 Exiting  

Either of the following methods can be used to exit the sequence editor:  
 

• Select exit on the [File] menu.  
• Select close on the control menu.  

 
4.1.6 Source list editing function 

(1) Creating a source file  

Source files can be created for registration on the sequence list. Since the execution 
mode is established immediately after startup, switch to the editing mode. The editing 
mode is selected automatically, however, when creating a new file is selected. 
Source files are displayed in the bottom half of the screen.  
If they are not displayed, check that the editing mode is established, and then check that 
[Source] on the [View] menu has a check mark.  

 
(2) How to create a new source file  

1. To create a new timing source file, select the Timing button on the source list to 
display a list of the timing source files. Similarly, the source lists are also displayed 
for pattern, palette set and action source files.  

2. Select the [New] menu item on the [Source] menu.  
The graphic pattern/bitmap pattern/option pattern selection dialog box is displayed 
with pattern files only. Select the pattern to be created and press the OK button.  
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3. The editing program now starts up. Proceed with editing, provide the file with a 

filename and save the data in the file.  
• When a new file has been created, its name is added to the source list. 
• When an existing file has been overwritten, the display of the file concerned on 

the source list is updated.  
 

For details on how to operate the editing program, refer to the item for the type of 
editing program concerned.  

 
(3) How to edit an existing source file  

1. On the source list, select one source file to be edited. More than one source file 
cannot be selected.  

2. Select the [Edit] menu item on the [Source] menu.  
The editing program now starts up, and the contents of the source file are displayed.  
• When the data of an existing file has been edited and saved by overwriting the 

pre-edited data, the display of that file on the source list is updated.  
• When a new file has been created and its data saved under another filename, the 

filename of that file is added to the source list.  
• When the data of an existing file has been overwritten and its data saved under 

another filename, the display of that file on the source list is updated. 

The same function is executed by double-clicking. 

 
(4) How to delete an existing source file  

Move the source file to the trash box directory.  
On the source list, select one or more source files to be deleted.  
Select the [Delete] menu item on the [Source] menu.  
The same function is executed by pressing the Delete key.  
It is also executed by dragging & dropping to the Trash button.  

 
(5) How to revive a source file deposited in the trash box  

A source file can be returned from the trash box to the source directory. Select the trash 
box button, and display a list of the source files in the trash box. Select one or more 
source files to be revived.  
Select the [Revive from Trash] menu item on the [Source] menu.  
In the case of timing source files, this same function is executed by dragging & dropping 
to the Timing button.  
It is also executed by dragging & dropping to the Pattern box for pattern source files, to 
the Palette Set button for palette set source files and to the Action button for action 
source files.  
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(6) How to delete a source file deposited in the trash box  

A selected source file can be completely deleted.  
Once deleted, it cannot be revived.  
Select the trash box button, and display a list of the source files in the trash box. Select 
one or more source files to be deleted.  
Select the [Delete] menu item on the [Source] menu.  
The delete confirmation message appears. Select YES.  
The same function is executed by pressing the Delete key.  
It is also executed by dragging & dropping to the Trash button.  
To delete all the source files in the trash box, select the [Empty Trash] menu item on the 
[Source] menu.  

 
(7) Copying source files  

An existing source file can be copied to create a source file under another name.  
Select one source file serving as the copy source.  
More than one source file cannot be selected.  
Select the [Copy As] menu item on the [Source] menu.  
Input the filename serving as the copy destination.  
An error results if the selected source filename already exists.  

 
(8) Renaming source files  

An existing source file can be renamed.  
Select the line where the filename is to be changed.  
More than one source filename cannot be selected.  
Select the [Rename As] menu item on the [Source] menu.  
Input the new filename.  
An error results if the selected source filename already exists. 

 
(9) Searching  

Character strings can be searched from the displayed list. 
Display the source list to be searched.  
Select the [Find] menu item on the [Source] menu.  
The same function is executed by pressing the F key while holding down the Ctrl key.  

 
(10) Finding source files from the sequence list.  

Character strings can be searched from the sequence list.  
Select one cell to be found from the sequence list.  
More than once cell cannot be selected.  
Select the [Find from Sequence] menu item on the [Source] menu. 

 
(11) Selecting all source files  

The displayed list can be set to the all select status.  
1. Display the source list with all the files to be selected. 
2. Select the [All Select] menu item on the [Source] menu.  

The same function is executed by pressing the A key while holding down the Ctrl key.  
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(12) Updating the source list  

All the source lists can be updated.  
Select the [Update All Source] menu item on the [Source] menu.  
When a sequence file is to be opened, the sequence editor loads the source files under 
the filenames in the source directory into the memory.  
When source files in the source directory have been deleted using the MS-DOS 
command or Explorer with the sequence file opened, the source list will be at variance 
from the contents of the sequence editor's memory. In a case like this, execute the source 
list update command. 

 
(13) How to execute source files  

1. Select the line with the file to be executed. More than one source file cannot be 
executed.  

2. Select the [Execute] menu item on the [Source] menu. 

In the execution mode, the same function is executed by double-clicking. 
 
4.1.7  Sequence list editing function  

(1) Registering source files on the sequence list  

Source files can be registered on the sequence list.  
Since the execution mode is established immediately after startup. switch to the editing 
mode. The editing mode is selected automatically, however, when creating a new file is 
selected.  
A blank (unregistered) cell on the sequence list is considered to contain the same data as 
the data which has been registered in the cell immediately above. If the cell immediately 
above is also blank, the cell above this cell is searched, and the blank cell is considered 
to contain the same data as the registered data which is found first.  
For this reason, sequential No.1, which is the top-most cell, must be registered without 
fail. An error display will appear if an attempt is made to execute a cell which is not 
registered.  
When selecting in line increments, select the No. cell.  
When selecting cells, make a selection other than the No. cell (Timing cell, Pattern cell, 
Palette Set cell, Action cell or Interval cell). 
Cells spanning different types (such as a Timing cell and a Pattern cell) cannot be 
selected. 
When the mouse's left button is clicked while holding down the Shift key, the same type 
of cells from the original cursor position to the position clicked by the mouse can be 
selected altogether. 
 
How to register timing, pattern, palette set and action names  

Dragging & dropping from the source list  
[Select] on the [Sequence] menu  
Inputting data names from the keyboard  
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(2) Dragging & dropping from the source list  

The data names selected on the source list can be registered by dragging the data name 
from the source list and dropping it on the sequence list.  
The drop destination area is displayed in green at this time.  
The dropping operation differs depending on the combination of two factors: whether 
one or more data is selected on the source list and whether one or more data is selected 
on the sequence list. 

 
[When one data has been selected on both the source list and sequence list]  

The data selected on the source list is registered in one drop destination cell on the 
sequence list. 

[When more than one data has been selected on the source list and one data has 
been selected on the sequence list]  

The data selected on the source list equivalent to the number selected on the source 
list starting with the drop destination cells on the sequence list is registered in 
sequence. 

[When one data has been selected on the source list and more than one data has 
been selected on the sequence list]  

If the drop destination on the sequence list is not the selected cell, the data selected 
on the source list is registered in one drop destination cell on the sequence list.  
If the drop destination on the sequence list is the selected cell, the data selected on 
the source list is registered in all the selected cells on the sequence list. 

[When more than one data has been selected on both the source list and sequence 
list]  

Multiple selections on the sequence list are ignored.  
The data selected on the source list equivalent to the number selected on the source 
list starting with the drop destination cells on the sequence list is registered in 
sequence. 

 
(3) [Select] on the [Sequence] menu  

The list of the source files which can be registered is displayed by selecting one or more 
cells to be used for the registration and then selecting [Select] on the [Sequence] menu.  
When one cell is selected and the OK button is pressed, the source file selected is 
registered in the cell selected on the sequence list.  
When more than one cell has been selected on the sequence list, the same data is 
registered in all the cells. 

 
(4) Inputting data names from the keyboard  

Data names can be registered directly by selecting one or more cells to be used for the 
registration and then inputting the data names from the keyboard.  
Only with pattern data does the pattern type (Graphic pattern. Bitmap pattern. Option 
pattern) selection dialog box appear. When more than one cell has been selected on the 
sequence list, the same data name is registered in all the cells. 
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(5) How to register intervals  

Intervals can be registered directly by selecting one or more cells to be used for the 
registration and then inputting a number from the keyboard.  
When more than one cell has been selected, the same number is registered in all the 
cells.  

 
4.1.8 Sequence list and other editing functions 

(1) Clearing the selected cell range  

1. Select one or more cells to be cleared.  
2. Select the [Clear] menu item on the [Sequence] menu.  

When cells are cleared, the cells themselves are not deleted but are simply left blank.  
 
(2) Deleting the selected cell range  

1. Select one or more cells to be deleted.  
2. Select the [Delete] menu item on the [Sequence] menu. 

The same function is executed by pressing the Delete key while holding down the 
Ctrl key. When cells are deleted, the cells themselves are deleted. Once they have 
been deleted by selecting [Delete], cells cannot be revived by Undo. 

 
(3) Moving the selected cell range to the clipboard  

1. Select one or more cells to be moved.  
2. Select the [Cut] menu item on the [Sequence] menu.  

The same function is executed by pressing the X key while holding down the Ctrl key.  
It is also executed by pressing the Cut button on the toolbar. 

 
(4) Copying the selected cell range to the clipboard  

1. Select one or more cells to be moved.  
2. Select the [Copy] menu item on the [Sequence] menu. 

The same function is executed by pressing the C key while holding down the Ctrl key.  
It is also executed by pressing the Copy button on the toolbar.  

 
(5) Pasting the selected cell range from this clipboard  

1. Select the lead cell to be pasted.  
2. Select the [Paste] menu item on the [Sequence] menu.  

Pasting in line increments takes the form of insertion above the selected cell.  
Pasting in cell increments takes the form of overwriting the selected cell.  
With pasting in cell increments, the pasting operation differs depending on the 
combination of two factors: whether one or more data is stored on the clipboard and 
whether one or more cells are selected on the sequence list. 
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[When one data is stored on the clipboard and one cell is selected on the sequence 
list]  

The data on the clipboard is pasted on the selected cell on the sequence list. 

 
[When more than one data is stored on the clipboard and one cell is selected on the 
sequence list] 

The data on the clipboard equivalent to the number of data on the clipboard starting 
with the selected cell on the sequence list is pasted in sequence. 

 

[When one data is stored on the clipboard and more than one cell is selected on the 
sequence list] 

The data on the clipboard clipboard is pasted in sequence on all the selected cells 
on the sequence list. 

 
[When more than one data is stored on the clipboard and more than one cell is 
selected on the sequence list] 

If the number of data selected on the clipboard differs from the number of data 
selected on the sequence list, an error message appears, and the data cannot be 
pasted. 
The data on the clipboard equivalent to the number selected starting with the 
selected cells on the sequence list is pasted in sequence.  
If the rows of the cells stored on the clipboard differ from the rows of the cells to 
be pasted, an error message appears, and the cells cannot be pasted. 
The same function is executed by pressing the V key while holding down the Ctrl 
key. It is also executed by pressing the Paste button on the toolbar. 

 
(6) Inserting lines  

1. To insert one line, select the No. cell in the line immediately below where the line is 
to be inserted.  
To insert more than one line, select the cells spanning the same number of lines as 
the number of lines to be inserted starting with the No. cell immediately below 
where the lines are to be inserted.  

2. Select the [Insert-up] menu item on the [Sequence] menu.  

The same function is executed by pressing the I key while holding down the Ctrl key. 
  
(7) Inserting cells  

1. To insert one cell, select a cell in the line immediately below where the cell is to be 
inserted. To insert more than one cell, select the cells spanning the same number of 
cells as the number of cells to be inserted starting with the cell immediately below 
where the cells are to be inserted. 

2. Select the [Insert-up] menu item on the [Sequence] menu.  

The same function is executed by pressing the I key while holding down the Ctrl key. 
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(8) Adding lines  

1. To add one line, select the No. cell in the line immediately above where the line is to 
be added.  
To add more than one line. select the cells spanning the same number of lines as the 
number of lines to be added starting with the No. cell immediately above where the 
lines are to be added.  

2. Select the [Insert-down] menu item on the [Sequence] menu. 

 
 (9) Adding cells  

1. To add one cell, select the cell in the line immediately above where the cell is to be 
added.  
To add more than one cell, select the cells spanning the same number of cells as the 
number of cells spanning the same number of cells as the number of cells to be 
added starting with the cell immediately above where the cells are to be added.  

2. Select the [Insert-down] menu item on the [Sequence] menu. 

 
(10) Searching cells  

This is for searching character strings from selected strings.  
1. Select the cell to be searched. Operation is the same even when more than one cell is 

selected. 
2. Select the [Find] menu item on the [Sequence] menu.  

The same function is executed by pressing the F key while holding down the Ctrl key. 
 
(11) Replacing cells  

1. Select the cell to be replaced. Operation is the same even when more than one cell is 
selected. 

2. Select the [Replace] menu item on the [Sequence] menu.  

This is for searching character strings and replacing them from selected strings. The 
same function is executed by pressing the R key while holding down the Ctrl key. 

  
(12) Finding a registered source file from the source list  

1. Select the cell to be found from the source list.  
More than one cell cannot be selected.  

2. Select the [Find from Source] menu item on the [Sequence] menu.  

The focus moves to the source file which has been found.  
This command cannot be executed when the source list is not displayed. 

  
(13) Changing the pattern offset/size  

1. Select one or more cells to be changed.  
2. Select the [Change Pattern Offset/Size] menu item on the [Sequence] menu.  
3. The current values are displayed. The display appears in gray when multiple cells 

are selected and the value differs. Change the values, and select the OK button.  
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(14) Changing Action/No Action  

1. Select one or more cells to be changed.  
2. Select the [Toggle Action/No Action] menu item on the [Sequence] menu. 

No Action is set in the blank cell. The cell which has been set appears in gray. A cell 
with the No Action setting has its setting cleared and goes blank. 

  
(15) Selecting all cells  

1. Select one row in which all the cells are to be set to the all select status.  
2. Select the [All Select] menu item on the [Sequence] menu.  

A11 the cells in the selected row are set to the selected status.  
The same function is executed by pressing the A key while holding down the Ctrl key. 

 
(16) Undoing the last operation  

Select the [Undo] menu item on the [Sequence] menu.  
This is for undoing the last operation.  
If the last operation cannot be undone. [Undo] on the [Sequence] menu appears in gray 
and cannot be selected.  
The same function is executed by pressing the Z key while holding down the Ctrl key.  
 
Operations which can be undone are listed below:  
• Dragging & dropping from the source list  
• [Select] on the [Sequence] menu  
• Inputting data from the keyboard  
• Clearing the selected cell range  
• Moving the selected cell range to the clipboard  
• Pasting the selected cell range from the clipboard (except for pasting in line 

increments)  
• Changing the pattern offset/size  
• Changing Action/No action  
 
Undo does not work (a gray display appears) for the following operations (accompanied 
by line shifts):  
• Deleting the selected cell range 
• Inserting lines  
• Inserting cells  
• Pasting lines from the clipboard (except for pasting in cell increments)  
• Adding lines  
• Adding cells  

 
(17)  Executing sequence lists in cell increments  

1. Select the cell to be executed.  
More than one cell cannot be selected.  

2. Select the [Execute] menu item on the [Sequence] menu.  
In the execution mode, the same function is executed by double-clicking. 

In the execution mode, this functions in the same way as with double-clicking. 
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(18) Executing the sequence list using the Execute button  

1. Select the cell where execution is to commence.  
The selection of more than one cell is ignored. In this case, execution starts from the 
highest of the numbers selected.  

2. Check the type of data to be executed in the execution data type check box. 
 
Select the execute button.  

Auto Exec 
button 

Used for auto 
execution 

Auto execution executes the current sequential 
No. and waits for the number of seconds in 
each interval. It then advances to the next 
sequential No., executes it, and waits for the 
number of seconds in the interval. If the repeat 
check box is checked, it returns to No.1 after 
the last No. Auto execution is repeated until the 
button is pressed again. If the repeat check 
box is not checked, auto execution is 
terminated when the last No. has been 
executed. 

Prev Step 
button 

Used for manual 
execution 

This is to return to the previous sequential No. 
and execute it. 

Next Step 
button 

Used for manual 
execution 

This is to advance to the next sequential No. 
and execute it. 

Execute 
button 

Used for manual 
execution 

This is to execute the current sequential No. 

 
When the Execute button is used, the data executed is all the data items checked in the 
execution data type check box. Only the data in the selected cell is executed if [Execute] 
on the mouse's right-click menu is used. Bear in mind that the data which is sent will 
differ. 

  
(19) How to edit registered source files  

The contents of a source file registered in the sequence list can be changed.  
This is virtually the same function as the one used to edit source files from the source 
list. It differs in that a message appears asking whether the sequence list is also to be 
changed when the file has been saved under a different name by the editing program. 

1. On the sequence list, select the source file to be edited.  
More than one source file cannot be selected.  

2. Select the [Edit] menu item on the [Sequence] menu.  
In the editing mode, the same function is executed by double-clicking.  
When the selected cell is blank, a dialog box appears asking whether an existing 
registered source file is to be edited in the cell above or a new source file is to be 
created. The cell being edited is displayed in red.  

3. The editing program starts up.  
When the file is now saved under a different name, a new source file can be created 
or an existing source file can be overwritten.  
When the file is to be saved under a different name, a confirmation message appears 
asking whether the registered name of the cell on the sequence list (the one 
displayed in red) is also to be changed.  
Select YES to change it; otherwise, select NO. 
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(20) Registering data inside the VG  

Source files can be exported (copied) to another directory. User characters and font sets 
can be registered in the board VG. Graphic patterns and option patterns are referenced 
for the user characters and font sets which have been registered. 
Since the execution mode is established immediately after startup, change to the editing 
mode. When new creation has been selected, however, the editing mode is selected 
automatically. 

 
(21) How to register user characters  

1. Select the [User Character Editor] menu item on the [Internal] menu.  
2. The character editor starts up.  

Refer to the section on the character editor for details on the editing program 
operations. 

 
(22) How to register font sets  

1. Select the [Font Set Editor] menu item on the [Internal] menu.  
The font editor starts up.  

2. Refer to the section on the font editor for details on the editing program operations. 
 

(23) Environment settings  

The following settings can be established.  

• At startup, open or do not open the sequence file which was last opened by the last 
startup  

• Sound or do not sound the buzzer when file loading, saving or executing files or 
registering files in the VG is successful 

1. Select the [Environment Options] menu item on the [Tools] menu.  
2. The environment settings dialog box appears.  

 
(24) Error check  

This is for checking the created sequence list for errors.  
An error results in the following cases:  

• When an unregistered cell is present at sequential No. l  
• When the registered source file does not exist 

1. Either press the Error button on the toolbar or select the [Error Check] menu item on 
the [Tools] menu. 
The error dialog box appears, and the error locations are displayed. 

 
(25) Importing source files 

Source files can be imported (copied) from another directory. 
Since the execution mode is established immediately after startup, change to the editing 
mode. When new creation has been selected, however, the mode is switched to editing 
automatically. 
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1. Select the [Import Source] menu item on the [Tools] menu. 
2. The copy source selection dialog box appears. 

Select the sample file or existing (user-created) file. 
3. The importable source files are displayed.  

At the outset, check marks are entered for all the source files.  
To import some source files and not others, enter the check mark only for those files 
which are to be imported. 

4. Select the Import button. 
The number of source files to be imported and a confirmation message are 
displayed. 
Source file importing is commenced when the OK button is pressed.  

 
(26) Exporting source files  

Source files can be exported (copied) to another directory. 
Since the execution mode is established immediately after startup, change to the editing 
mode. When new creation has been selected, however, the mode is switched to editing 
automatically. 

1. Select the [Export Source] menu item on the [Tools] menu. 
2. The copy destination selection dialog box appears.  

Select the copy destination directory. 
3. The exportable source files are displayed.  

At the outset, check marks are entered for all the source files.  
To export some source files and not others, enter the check mark only for those files 
which are to be exported.  

4. Select the Export button. 
The number of source files to be exported and a confirmation message are displayed.  
Source file exporting is commenced when the OK button is pressed.  

 
(27) Checking whether a source file has been used by another sequence file  

It is possible to check whether a source file has been used by another sequence file.  
Since the execution mode is established immediately after startup, change to the editing 
mode. When new creation has been selected, however, the mode is switched to editing 
automatically.  

1. Select the [Find Source from Other Sequence] menu item on the [Tools] menu.  
2. Select one source to check as to whether it has been used by another sequence file. 
3. Select the sequence file where the search is to begin. 

At the outset, check marks are entered for all the sequence files.  
To search some sequence files and not others, enter the check mark only for those 
files which are to be searched.  

4. Select the Find button. The number of sequence files to be searched and a 
confirmation message are displayed. The search is commenced when the OK button 
is pressed. 

 



 
SP-8022-2 Help (Instruction Manual) 

 4-20 

 

(28) Opening an existing sequence file  

An existing sequence file can be opened. 

1. Either press the Open button or select the [Open Sequence] menu item on the File] 
menu. 

2. The file selection dialog box opens. Select the file.  

 
(29) Saving data in a sequence file 

The data in the currently open file can be saved while overwriting the existing data in 
that file. Either press the Save button or select the [Save Sequence] menu item on the 
[File] menu. 

 
(30) Saving data in a sequence file under another filename 

Data in the currently open sequence file can be saved under another filename. 

1. Either press the Save As button or select the [Save As Sequence] menu item on the 
[File] menu. 

2. The file selection dialog box opens. Input the filename. 
 

(31) Reopening a sequence file  

An existing sequence file can be opened. 

• Select the file to be opened from among the files registered in [Reopen Sequence] on 
the [File] menu. 

 
(32) Closing a sequence file  

The sequence editor can be exited. 

• Either select the [Close Sequence] menu item on the [File] menu or select closing 
the control menu. 

 
(33) Printing the display data 

The data being edited can be printed. 

• Either select the [Print] menu item on the [File] menu or select the [Print] button 
from the tool buttons. 

 
(34) Output control  

The VG output condition settings can be displayed in real time. These conditions are set 
using timing editor Output.  
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Fig. 4-4 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

(35) Sorting  

The sequence in which the source files are listed on the source list can be sorted. Sorting 
is executed by pressing the column header in the list. 

 
(36) Sequence list mouse right click menu (Timing)  

When the mouse's right button is clicked on the sequence list, the following menu 
appears.  
 

Execute Executes only the selected timing data file. 

Select  Sets the file in the selected cell. More than one cell can be 
selected but only one file can be set. 

Edit Loads the timing data file registered in the selected cell and 
starts up the timing editor. 

Clear Clears the data in the selected cell range. This data can be 
restored by undoing the clearing. 

Copy Copies the selected cell range. 
Cut Cuts out the selected cell range on the clipboard. 
Paste Pastes the selected cell range from the clipboard. 
All Select Selects all the cell data in the selected row of the sequence list. 

Insert-up Adds a cell (or line) immediately above the selected cell (or 
line). 

Insert-down Adds a cell (or line) immediately below the selected cell (or line).

Delete Deletes the selected cell (or line) and carries the data forward. 
Deleted data cannot be undone. 

Find Searches. 
Replace Replaces. 
Find from Source Finds registered source files from the source list. 
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(37) Sequence list mouse right click menu (Pattern)  

When the mouse's right button is clicked on the sequence list, the following menu 
appears.  

Execute Executes only the selected pattern data file. 

Select Sets the file in the selected cell. More than one cell can be 
selected but only one file can be set. 

Edit Edits the file registered in the selected cell, and starts up the 
editor 

Clear Clears the data in the selected cell range. This data can be 
restored by undoing the clearing. 

Copy Copies the selected cell range. 
Cut Cuts out the selected cell range on the clipboard. 
Paste Pastes the selected cell range from the clipboard. 
All Select Selects all the cell data in the selected row of the sequence list. 

Insert-up Adds a cell (or line) immediately above the selected cell (or 
line). 

Insert-down Adds a cell (or line) immediately below the selected cell (or line).

Delete Deletes the selected cell (or line) and carries the data forward. 
Deleted data cannot be undone. 

Find Searches. 
Replace Replaces. 
Find from Source Finds registered source files from the source list. 
Change Pattern 
Offset/Size Changes the pattern offset/size.  

 
 

(38) Sequence list mouse right click menu (Palette Set) 

When the mouse's right button is clicked on the sequence list, the following menu 
appears.  
 

Execute Executes only the selected palette set file. 

Select Sets the file in the selected cell. More than one cell can be 
selected but only one file can be set. 

Edit Loads the palette set file registered in the selected cell, and 
starts the timing editor. 

Clear Clears the data in the selected cell range. This data can be 
restored by undoing the clearing 

Copy Copies the selected cell range. 
Cut Cuts out the selected cell range on the clipboard. 
Paste Pastes the selected cell range from the clipboard. 
All Select Selects all the cell data in the selected row of the sequence list. 
Insert-up Adds a cell (or line) immediately above the selected cell (or line)
Insert-down Adds a cell (or line) immediately below the selected cell (or line)

Delete Deletes the selected cell (or line) and carries the data forward. 
Deleted data cannot be undone. 

Find Searches. 
Replace Replaces. 
Find from Source Finds registered source files from the source list. 
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(39) Sequence list mouse right click menu (Action)  

When the mouse's right button is clicked on the sequence list, the following menu 
appears.  
 

Execute Executes only the selected action data file. 

Select Sets the file in the selected cell. More than one cell can be 
selected but only one file can be set. 

Edit Loads the file registered in the selected cell, and starts up the 
action editor. 

Clear Clears the data in the selected cell range. This data can be 
restored by undoing the clearing. 

Copy Copies the selected cell range. 
Cut Cuts out the selected cell range on the clipboard. 
Paste Pastes the selected cell range from the clipboard. 
All Select Selects all the cell data in the selected row of the sequence list. 
Insert-up Adds a cell (or line) immediately above the selected cell or line).
Insert-down Adds a cell (or line) immediately below the selected cell (or line).

Delete Deletes the selected cell (or line) and carries the data forward. 
Deleted data cannot be undone. 

Find Searches. 
Replace Replaces. 
Find from Source Finds registered source files from the source list. 
Toggle Action/ 
No Action 

Establishes the No Action setting in the blank cell. The setting 
for a No Action cell is released, and the cell goes blank.  

 
(40) Sequence list mouse right click menu (Interval) 

When the mouse's right button is clicked on the sequence list, the following menu 
appears.  
 

Edit Establishes the input mode for the cell. 

Clear Clears the data in the selected cell range. This data can be 
restored by undoing the clearing. 

Copy Copies the selected cell range. 
Cut Cuts out the selected cell range on the clipboard. 
Paste Pastes the selected cell range from the clipboard. 
All Select Selects all the cell data in the selected row of the sequence list. 

Insert-up Adds a cell (or line) immediately above the selected cell (or 
line). 

Insert-down Adds a cell (or line) immediately below the selected cell (or line).

Delete Deletes the selected cell (or line) and carries the data forward. 
Deleted data cannot be undone. 

Find Searches. 
Replace Replaces. 
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(41) Source list mouse right click menu  

When the mouse's right button is clicked on the source list, the following menu appears. 
 

Execute Executes the selected source file. 
Update All Source Updates the source list. 
All Select Selects all the files. 
New Starts up the editor and creates a new source file. 
Edit Starts up the editor and edits the selected file. 
Copy As Copies the selected file into a file under another name. 
Rename As Updates the filename. 
Delete Moves the file from the source list to the trash box. 
Find Searches the source list. 
Find from Sequence Searches the sequence list.  

 
(42) List of shortcuts 

Shortcuts using action keys  
 

F9 key Executes the selected cell. 
F9 10 key Selects the menu bar.  

 
Press the applicable key while holding down the Ctrl key.  
 

Key operation Objective 

Ctrl + A keys 
Selects all the cells on the selected row.  
The same function is executed by [All Select] on the Sequence 
menu. 

Ctrl + C keys Copies the selected cell.  
The same function is executed by [Copy] on the [Sequence] menu

Ctrl + F keys 
Selects all the cells on the selected row.  
The same function is executed by [Source Find] on the 
[Sequence] menu. 

Ctrl + I keys 
Adds a cell (or line) immediately above the selected cell (or line). 
The same function is executed by [Insert-Up] on the [Sequence] 
menu. 

Ctrl + R keys 
Replaces.  
The same function is executed by [Replace] on the [Sequence] 
menu. 

Ctrl + V keys 
Pastes the selected cell range from the clipboard.  
The same function is executed by [Paste] on the [Sequence] 
menu. 

Ctrl + X keys Cuts out the selected cell range on the clipboard.  
The same function is executed by [Cut] on the [Sequence] menu. 

Ctrl + Z keys 
Undoes the last operation. 
The same function is executed by [Undo] on the [Sequence] 
menu. 

Ctrl + Delete 
keys 

Deletes the selected cell. 
The same function is executed by [Delete] on the [Sequence] 
menu. 
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4.2 Timing editor 

How to set the timing data of the programmable video signal generator (referred to henceforth as the 
"VG") is described in this section. This program enables timing data for the VG to be edited in 
Windows and edited timing data to be sent to the VG and executed.  

 
4.2.1 Startup method 

Start up the program from the sequence editor. (For details, refer to section on the sequence 
editor.) When the program is started up, the timing data setting screen is displayed. The 
timing data registered in the selected sequence list or displayed on the selected source list is 
loaded.  

 
4.2.2 Window screen and names 

When the timing settings have been selected. 

Fig. 4-5  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

(1) Timing data setting operations 

[Data setting] 
• Place the mouse cursor on the data to be changed, and click. New data can now be 

keyed in.  
 
[Input mode setting] 
• Select usec or dot for the horizontal timing (H TIMING) and msec, H or Hz for the 

vertical timing (V TIMING). The check box enabling input now changes. 

Error button 

Timing setting button 

Timing setting screen

Output condition setting button
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[Fixed mode setting] 
• The fixed mode ensures that the DotClock, Period and Disp horizontal timing (H 

TIMING) data and Total and Disp vertical timing (V TIMING) data remains 
unchanged as a result of changes made to other data (such as DotClock and Period). 
Check the fixed mode when the data is not to be changed.  

 
When the output condition settings have been selected 

Fig.4-6 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

(2) Output condition setting operations  

[Data setting] 
• Set the items on the left side. Select the radio buttons.  
• In the case of the edit box, place the mouse cursor on the data to be changed, and 

click. New data can now be keyed in. 
 

Error button 

Output condition setting 
screen 

Output condition setting button

Timing setting button 
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Error button 
The error window appears when the      button is clicked. Check the values of the data set. 
If any values which have been input are outside the setting range, the error locations will be 
displayed on the error display screen.  
The error window also appears when [Error Window] is selected on the [View] menu. 

 
Fig. 4-7 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Error display screen 
The error locations are displayed on this screen.  
 
Update 
This is used for updating to the latest information.  
 
Close 
This is used to exit the error display. 
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4.2.3 Timing data settings 
(1) Timing data setting ranges 

[Frequencies] 
Dot clock frequency 5.000 to 165.000MHz 
Horizontal sync frequency 10.000 to 300.000KHz 
Vertical sync frequency 15.600 to 200.000Hz 

 
[Horizontal timing data] 

H Period 0.000 to 99.999 µsec 68 to 4096 dots 2-dot increments 
H Disp 0.000 to 99.999 µsec 26 to 2048 dots 2-dot increments 
H Sync 0.000 to 99.999 µsec 2 to 4088 dots 2-dot increments 
H Back  0.000 to 99.999 µsec 
H Frontp 0.000 to 99.999 µsec 

0 to 4084 dots 2-dot increments 

HD start 
HD width 0.000 to 99.999 µsec 0 to 4084 dots 

(Note 2, Note 3) 2-dot increments 

H Blanking Automatically calculated 42 dots - 2-dot increments 
Note 1: Even when settings are made in µsec units, the setting range for the number of dots given 

above must be satisfied. 
Note 2: In order for the HD data to be generated error-free, set H Period, H Disp, H Sync and H 

Back all in 2-dot increments.  
Note 3: The HD start and HD width whose sum exceeds H Period cannot be set. 

 
[Vertical timing data] 

4.0 to 8192.0H 
(non-interlace) 0.5H increments 

V Total 0.000 to 99.999µsec 4.0 to 4096.0H 
(interlace) 0.5H increments 

V Disp 0.000 to 99.999µsec 1.0 to 2048.0H 0.5H increments 
V Backp 0.000 to 99.999µsec 0.0 to 4096.0H 0.5H increments 
V Sync 0.000 to 99.999µsec 2.0 to 4096.0H 0.5H increments 
EQP FP 
EQP BP 0.000 to 99.999µsec 0.0 to 4096.0H 0.5H increments 

VD Start 
VD Line 0.000 to 99.999µsec 0.0 to 4095.0H 

(Note 6) 0.5H increments 

More than 80µsec Vertical frequency ≥ 62.500 Hz 
More than 150µsec Vertical frequency ≥ 31.300 Hz V Blanking 
More than 280µsec Vertical frequency ≥ 15.600 Hz 

Note 4: Even when settings are made in msec units, the setting range for the H number given 
above must be satisfied.  

Note 5: The number of scanning lines per field is set for interlace & sync and video. The same 
applies for the VSync through DV Line data. 

Note 6: The VD Start and VD Line whose sum exceeds V Period cannot be set. 
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(2) Horizontal timing data  

Concerning differences in operation based on the input mode  
 
1. In the dot input mode  

The µsec items are recalculated without changing the dot items of the data.  

Input of dot clock The µsec items are recalculated without changing the 
dot items of the data. 

Input of other items The µsec items are recalculated on the basis of the dot 
items of the input data.  

 
2. In the µsec input mode  

Basically, the dot items are calculated in such a way that the µsec items of the data 
are not changed. Based on the calculated number of dots and dot clock data, the µsec 
items are then recalculated.  

Input of dot clock 

The number of dots for each item is calculated in such a 
way that the data in µsec units for each item is not 
changed. Based on the calculated number of dots, the 
µsec figure for each item is recalculated. 
(The dot clock data is compensated in such a way that 
the µsec figures of H period are not changed.) 

Input of other items

The corresponding dot items are calculated on the basis 
of the µsec items of the input data. Based on the 
calculated dot items, the µsec items are recalculated.  
(For H period and H disp, the dot clock data is 
compensated so as to optimize with the input µsec 
data.)  

 
3. In the KHz input mode  

Operation is basically the same as for the µsec items, but the dot clock data is 
compensated in such a way that Freq is not changed.  

 
(3) Vertical timing data  

Concerning differences in operation based on the input mode  
 
1. In the H input mode  

msec and Freq are recalculated without changing the H items of the data.  

2. In the µsec input mode  
Basically, the H items are calculated in such a way that the msec items of the data 
are not changed. Based on the calculated number of H and horizontal period, the 
msec and Freq are then recalculated.  

3. In the Hz input mode  
Operation is basically the same as for the msec items, but Total is compensated in 
such a way that Freq is not changed. 
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(4) Output condition settings  

These are for setting the output conditions. 
 

HS For selecting the HS polarity. 
VS For selecting the VS polarity. 
CS For selecting the CS polarity. 
Clock For selecting the clock. (Not supported) 
HD For selecting the HD polarity. 
VD For selecting the VD polarity. 

NEGA/POSI 

DISP For selecting the DISP polarity. 
HS For selecting ON or OFF for HS. 
VS For selecting ON or OFF for VS. 
CS For selecting ON or OFF for CS. 
G/S For selecting G/S. 
HD For selecting ON or OFF for HD. 
VD For selecting ON or OFF for VD. 
DISP For selecting ON or OFF for DISP. 

ON/OFF 

ON SYNC For selecting ON or OFF for ON SYNC. 
HS/HD For selecting either HS or HD. 
LVDS For selecting ON or OFF for LVDS. 

 

DVI For selecting ON or OFF for DVI. 
 
4.2.4 Menus 

(1)  [File] menu 
Menu command Function 

Load Loads data from a file. 
Load Sample  Loads the sample data from a sample file. 
Save Saves the data in a file. 

Save As Changes the data filename and saves the data in that 
file. 

Execute Executes the display data. 
Properties Displays the file properties. 
Print Prints the display data. 
Exit Timing Editor Exits the program. 

 
(2) [View] menu 

Menu command Function 
Timing Displays the timing data setting screen. 
Output Displays the output setting screen. 
Error Window Displays the error window. 

 

(3) [Help] menu 
Menu command Function 

Contents Displays the help contents. 
Index Enables help topics to be searched. 
About Displays the version information. 
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4.2.5 Operating procedure 
(1) Error window  

The values of the data set are checked on this window.  
If any values are outside the setting range, the error locations will be displayed on the 
error display screen. 
 
• Either select the [Error Window] menu item on the [View] menu or select the  

     button from the tool buttons. 

 

(2) Loading data  

The data of the selected file can be loaded. 
The same filename as at startup is retained. 
 
• Either select the [Load] menu item on the [File] menu or select the      button 

from the tool buttons. 
• The source directory is now displayed. 

 

(3) Loading sample data  

The data can be loaded from the sample file in the sample directory.  
The same filename as at startup is retained. 
 
• Select the [Load Sample] menu item on the [File] menu. 
• The sample directory is now displayed. 

 

(4) Saving data  

The edited data can be saved in the file while overwriting the existing data in that file. 
 
• Either select the [Save] menu item on the [File] menu or select the      button 

from the tool buttons. 
• The data is now saved in the source directory. 

 

(5) Saving data as 

A new filename can be created and the data saved in that file. The name on the sequence 
list of the sequence editor is also changed to the new filename. 
 
• Either select the [Save As] menu item on the [File] menu or select the      button 

from the tool buttons.  
• The source file which has now been created is saved in the source directory which 

was set when the sequence editor was started up. 

 

(6) Executing data 

The data being edited can be sent to the VG and executed.  
 
• Either select the [Execute] menu item on the [File] menu or select the     button 

from the tool buttons.  
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(7) Printing the displayed data  

The displayed data can be printed.  
 
• Either select the [Print] menu item on the [File] menu or select the       button 

from the tool buttons.  

 
(8) Exiting the program  

The program can be exited. 
 
• Select the [Exit Timing Editor] menu item on the [File] menu. 
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4.3 Graphic editor 

The graphic pattern editor program enables the rendition of images displayed on the VG to be edited 
using the graphical user interface. 
 
Window screen and names 
 
Fig. 4-8 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Edit window enlargement/reduction 
The display on the edit window can be enlarged or reduced. The magnification factor is 10, 
20, 50, 75, 100, 150, 200, 400, 800% or 1:1 (original size). 

  
Edit window 

This is the area in which the parts are placed and the data is created. The screen size can be 
changed using Data Properties. 
Either select the [Data Property] menu item on the [Edit] menu or select      on the toolbar. 

  
Parts box window 

This is for displaying a list of the graphic parts.  
When a part is selected (when the corresponding part is clicked) and clicked on the edit 
window, a graphic part is added.  

 
Parts properties display area 

This is for displaying the properties of the graphic part now being selected on the parts box 
window. The properties change depending on the part type, and are set as required. 

 

Parts box window 

Parts properties 
display area 

Edit window Status bar

Edit window 
enlargement/ 

reduction 

Parts No. 

View No. 



 
SP-8022-2 Help (Instruction Manual) 

 4-34 

 
Status bar  

This is for displaying the number of parts, screen size, types of parts and cursor position. 
 

Parts No.  
This is for displaying the parts number.  
The parts are numbered in the sequence in which they were added.  

 
View No.  

This is for displaying the sequence in which the parts are rendered.  
The display numbers are normally in the sequence in which the parts were added, but they are 
changed when the parts are moved to the front of the screen or back of the screen. 

 
4.3.1 Menus 

(1) [File] menu 
Load Loads data from a file 
Load Sample Loads the sample data from a sample file. 
Save Saves the data in a file. 
Save As Changes the data filename and saves the data in that file. 
Execute Executes the display data. 
Select Parts Save Saves the selected parts. 
Property Displays the file properties. 
Exit Gpc Editor Exits the program. 

 
(2) [Edit] menu 
Undo Undoes (restores) the last operation. 
Copy Copies the selected parts. 
Cut Cuts the selected parts. 
Paste Pastes the cut or copied parts. 
Delete Deletes the selected parts. 
Group On Groups together multiple selected parts. 
Group Off Ungroups parts. 
Insert Inserts the parts data of another file. 
All Clear Clears all the parts. 
Data Property Opens the pattern data properties dialog box. 

 
(3) [View] menu 
Palette View Displays the palette settings. 
Grid View Displays the grid. 
Grid Positioning Aligns the parts with the grid position. 
Parts List Displays the registered parts lists on the edit window. 
Full View Displays the edit window on the full screen. 

 
(4) [Help] menu 
Contents Displays the help contents. 
Index Enables help topics to be searched. 
About Displays the version information. 
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(5) Right-click menu 

When the mouse is right-clicked on the edit window while parts are being selected, the 
right-click menu appears. 
 

Front Move Moves the parts to the front of the screen. 
Back Move Moves the parts to the back of the screen. 
Group On Groups the parts together. 
Group Off Ungroups the parts. 
Copy Copies the parts. 
Cut Cuts the parts. 
Paste Pastes the parts. 
Delete Deletes the parts. 

 
4.3.2 Operating procedure  

(1) Loading data  

The data of the selected file can be loaded.  
 
• Either select the [Load] menu item on the [File] menu or select the     button from 

the tool buttons.  
• The source directory is now displayed. 

 
Fig. 4-9 

Drive box  
This is where the drive is 
designated.  
It is selected on the drop-down list.  

Directory box  
This is where the directory is 
selected.  

File list box  
This is where the files (which are 
displayed without their 
extensions) are selected. 

File edit box  
This is where the filenames (which are displayed without their extensions) are input.  

Comment edit box  
This is where the comments (which cannot be edited) are displayed.  

 

Directory box 

File list box 

Comment edit box

File edit box 

Drive box



 
SP-8022-2 Help (Instruction Manual) 

 4-36 

 

(2) Loading sample data  

Data can be loaded from a sample file in the sample directory. The same filename as at 
startup is retained. 

• The sample directory is now displayed. 
• Since the sample data is always loaded from the same drive and directory, the drive 

box and directory box cannot be changed. 
 

(3) Saving data  

The displayed data can be saved in a file.  
When the program was started up from the source list of the sequence editor, the data is 
saved under the filename used at startup.  

• The data is now saved in the source directory. 
 

(4) Saving data as  

A new filename can be created and the data saved in that file.  
The name on the source list of the sequence editor is also changed to the new filename.  

• The source file which has now been created is saved in the source directory which 
was set when the sequence editor was started up. 

 

(5) Exiting the program  

The program can be exited.  
When the program was started up from the source list of the sequence editor, the 
filename at exiting is registered on the source list.  

 

(6) Deleting parts    

Either press [Ctrl] + [DEL] while the part is being selected on the edit window or select 
[Delete] on the [Edit] menu.  
Select [Delete] on the right-click menu.  

 

(7) Copying parts   

The part being selected can be copied onto the clipboard or onto the place equivalent to 
the clipboard.  

 

(8) Cutting parts   

The part being selected can be moved to the clipboard or to the place equivalent to the 
clipboard.  

 

(9) Pasting parts   

The cut or copied data can be pasted on the edit window. This command cannot be used 
if no data has been cut or copied.  
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(10) Undoing (restoring the original)   

The last operation conducted on the edit window can be undone.  
Operations which can be undone include adding a part, deleting a part, editing the 
properties of a part, grouping parts together, ungrouping parts, positioning and all clear.  
Eight operations can be undone. 

 

(11) Displaying the palette   

The settings of the palette which was set by data properties can be displayed. 
 
Fig. 4-10  

 
 
 
 
 
 
 
 
 
 
 
 

No. The palette numbers are displayed here. 
Pal The palette colors are displayed here. 

RGB The elements (0 to 255) of the colors configuring the 
palette are displayed here. 

Browse button This opens the palette data reference dialog box.  
 

 

(12) Data properties  

The pattern data properties (coordinate-related settings and palette selection) can be 
changed.  
 
Fig. 4-11 
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WC (World 
Coordinate) 

The aspect ratio of the screen must be set with a number 
0 to 10000 for ranges X and Y, and this ratio is used to 
align the display image. 

LDC (Logical 
Device 
Coordinate) 

This is for designating the home point on the physical 
device when patterns are created. 

Aspect Ratio The aspect ratio is set here. 

Size 
The screen size is set here. 
The timing data reference dialog box opens when the 

        button is pressed. 

Palette Name 
The palette to be used is set here.  
The palette data reference dialog box opens when the 

        button is pressed. 
 

 

(13) Executing data  

What has been currently edited can be sent to the VG and drawn.  
 

 

(14) Displaying the parts list  

A list of the parts which have been registered can be displayed in the edit window.  
When a parts list is selected, the corresponding parts on the edit window are selected.  
 
Fig. 4-12  

 
 
 
 
 
 
 
 
 
 
 
 

Parts Kind The parts names are displayed here. When the item button is 
right-clicked, names can be masked by individual part. 

Cmd No. 
The command are displayed here. When the item button is 
right-clicked, the numbers can be changed in ascending or 
descending order. 

Parts No. 
The parts numbers are displayed here. When the item button 
is right-clicked, the numbers can be changed in ascending or 
descending order. 
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4.3.3 Parts preparation  

(1) Clearing all parts  

All the parts can be cleared and the edit window cleared.  
Select the [All Clear] menu item on the [Edit] menu.  

 
(2) Adding parts  

A part can be selected from the parts box window and clicked on the edit window.  
 

 
Dot This is for drawing a dot. 

 
Line This is for drawing a straight line. 

 
Rectangle This is for drawing a rectangle. 

 
Triangle This is for drawing a triangle. 

 
Ellipse This is for drawing an ellipse. 

 
Character This is for drawing a character. 

 
Character string This is for drawing a character string. 

 
Window This is for drawing a window. 

 
Crosshatch pattern This is for drawing a crosshatch pattern. 

 
Dot pattern This is for drawing a dot pattern. 

 
Block pattern This is for drawing a block pattern. 

 
Character pattern This is for drawing a character pattern. 

 
Burst pattern This is for drawing a burst pattern. 

 
Edge mark pattern This is for drawing an edge mark pattern 

(rectangle of the whole display area). 

 
Center pattern This is for drawing a center mark pattern  

(a cross in the center of the display area) 
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(3) Selecting parts 

Select the     button on the parts box window.  
When a part is clicked on the edit window, the part is set to the selected status, and 
detailed information is displayed in the properties display area.  
Multiple parts can be selected by [Ctrl] + [click].  
When a part is right-clicked while it is being selected, the right-click menu appears. The 
necessary command can now be executed by clicking.  

 
(4) Editing parts  

Moving, enlarging/reducing, changing the color and other editing operations can be 
performed by editing the properties in the properties display area.  
Select the part on the edit window, and change the settings in the properties display area.  

 
(5) Grouping parts and ungrouping parts  

The parts grouping command groups multiple selected parts together. Grouped parts can 
be cut, copied, moved or deleted altogether.  
Parts can be grouped together when the multiple parts are selected on the edit window 
and the [Group On] menu item on the [Edit] menu is selected. (They can also be 
grouped together using [Group On] on the right-click menu.)  
To ungroup the parts, select the parts which have been grouped together, and select the 
[Group Off] menu item on the [Edit] menu.  
(They can also be ungrouped using [Group Off] on the right-click menu.)  

 
(6) Changing the parts drawing sequence  

The parts drawing sequence can be rearranged using the right-click menu.  
The parts move to the front of the screen when the parts are selected on the edit window 
and [Front Move] on the right-click menu is selected. They move to the back of the 
screen when [Back Move] is selected.  

 
(7) Adding dots  

1. Select the     button on the parts box window.  
2. Set the properties in the parts properties display area.  
3. A part is added when it is clicked on the edit window.  
4. To change the properties of a part which has already been added, select the part to be 

edited, and change the properties in the parts properties display area.  

Fig. 4-13  
 
 
 
 
 
 

Color The drawing color (palette No.) is set here. 
Rop The drawing mode (Set, Or, And) is set here. 
X, Y The XY coordinates (LDC or WC) are set here 
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(8) Adding lines 

1. Select the      button on the parts box window.  
2. Set the properties in the parts properties display area.  
3. A part is added when it is clicked on the edit window.  
4. To change the properties of a part which has already been added, select the part to be 

edited, and change the properties in the parts properties display area.  

Fig. 4-14  
 
 
 
 
 
 
 
 

Color The drawing color (palette No.) is set here. 
Rop The drawing mode (Set, Or, And) is set here. 
TX, TY The XY coordinates (LDC or WC) for the start point are set 

here. 
EX, EY The XY coordinates (LDC or WC) for the end point are set 

here.  
 

(9) Adding rectangles 

1. Select the     button on the parts box window.  
2. Set the properties in the parts properties display area.  
3. A part is added when it is clicked on the edit window.  
4. To change the properties of a part which has already been added, select the part to be 

edited, and change the properties in the parts properties display area.  

Fig. 4-15  
 
 
 
 
 
 
 
 
 

Color The drawing color (palette No.) is set here. 
Rop The drawing mode (Set, Or, And) is set here. 
Fill Filling (filling or no filling) is set here. 
Left, Top, 
Right, Bottom 

The coordinates (LDC or WC) and the horizontal and 
vertical direction coordinates are set here. 
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(10) Adding triangles  

1. Select the     button on the parts box window.  
2. Set the properties in the parts properties display area.  
3. A part is added when it is clicked on the edit window.  
4. To change the properties of a part which has already been added, select the part to be 

edited, and change the properties in the parts properties display area.  

Fig. 4-16 
 
 
 
 
 
 
 
 
 

Color The drawing color (palette No.) is set here. 
Rop The drawing mode (Set, Or, And) is set here. 
Fill Filling (filling or no filling) is set here. 
X1, Y1, .. , 
X3, Y3 

The triangular coordinates as the XY coordinates  
(LDC or WC) are set here.  

 

(11) Adding ellipses  

1. Select the     button on the parts box window.  
2. Set the properties in the parts properties display area.  
3. A part is added when it is clicked on the edit window.  
4. To change the properties of a part which has already been added, select the part to be 

edited, and change the properties in the parts properties display area.  

Fig. 4-17 
 

  
 
 
 
 
 
 
 

Color The drawing color (palette No.) is set here. 
Rop The drawing mode (Set, Or, And) is set here. 
Fill Filling (filling or no filling) is set here. 
CX, CY The XY coordinates (LDC or WC) for the center are set here. 
RX, RY The XY coordinates (LDC or WC) for the radius are set here. 
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(12) Adding characters  

1. Select the     button on the parts box window.  
2. Set the properties in the parts properties display area.  
3. A part is added when it is clicked on the edit window.  
4. To change the properties of a part which has already been added, select the part to be 

edited, and change the properties in the parts properties display area.  

Fig. 4-18  
 
 
 
 
 
 
 
 
 
 

Char Code The character code is input here. ('C': default) 
Rop The drawing mode (Set, Or, And) is set here. 
Color The drawing color (palette No.) is set here. 
BkColor The character background color (palette No.) is set here. 
Font The font size is set here. 

TX, TY  The XY coordinates (LDC or WC) for the start point are set 
here.  

 

(13) Adding character strings  

1. Select the     button on the parts box window  
2. Set the properties in the parts properties display area.  
3. A part is added when it is clicked on the edit window.  
4. To change the properties of a part which has already been added, select the part to be 

edited, and change the properties in the parts properties display area.  

Fig. 4-19 
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Alignment Left- or right-justifying the character strings is set here. 
Rop The drawing mode (Set, Or, And) is set here. 
Color The drawing color (palette No.) is set here. 
BkColor The character background color (palette No.) is set here. 
TX, TY The XY coordinates (LDC or WC) for the start point are set here. 
h_cell, 
v_cell 

The character interval (h_cell) and line interval (v_cell) are set 
here. 

Edit Box The character strings are input here.  
Up to 256 digits can be input. 

 

(14) Adding windows   

1. Select the     button on the parts box window. 
2. Set the properties in the parts properties display area.  
3. A part is added when it is clicked on the edit window.  
4. To change the properties of a part which has already been added, select the part to be 

edited, and change the properties in the parts properties display area.  

* Multiple windows cannot be drawn. To draw a window at a new position, either 
change or delete the window which has been drawn.  

 
Fig. 4-20  
 
 
 
 
 

 
 

Set The drawing operation is set here. 
Left, Top, 
Right, Bottom 

The coordinates (LDC or WC) and the horizontal and vertical 
direction coordinates are set here. 

 

(15) Adding crosshatch patterns  

1. Select the     button on the parts box window.  
2. Set the properties in the parts properties display area.  
3. A part is added when it is clicked on the edit window.  
4. To change the properties of a part which has already been added, select the part to be 

edited, and change the properties in the parts properties display area.  



 
SP-8022-2 Help (Instruction Manual) 

 4-45 

 
Fig. 4-21  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Color The drawing color (palette No.) is set here. 

Mode The display mode (line number designation or dot 
designation) is set here. 

Format The display method (from the center or from the top left) is set 
here. 

Interval H, 
Interval V 

The horizontal and vertical intervals (number of lines with the 
line designation or line interval with the dot designation) are 
set here. 

Width H, 
Width V The horizontal and vertical line widths are set here. 

Area The display area (whole display area or limited area 
designation) is set here. 

Left, Top, 
Right, Bottom 

The coordinates (LDC or WC) and the horizontal and vertical 
direction coordinates are set here.  

 

(16) Adding dot patterns  

1. Select the     button on the parts box window.  
2. Set the properties in the parts properties display area.  
3. A part is added when it is clicked on the edit window.  
4. To change the properties of a part which has already been added, select the part to be 

edited, and change the properties in the parts properties display area. 
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Fig. 4-22  
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

Color The drawing color (palette No.) is set here. 

Area The display area (whole display area or limited area 
designation) is set here. 

Mode The display mode (line number designation or dot 
designation) is set here. 

Format The display method (from the center or from the top left) is set 
here. 

Interval H, 
Interval V 

The horizontal and vertical intervals (number of lines with the 
line designation or line interval with the dot designation) are 
set here. 

Size The dot size (diameter) is set here. 

Figure The dot shape (round or square) is set here. 
(Square when a check mark is used.) 

Left, Top, 
Right, Bottom 

The coordinates (LDC or WC) and the horizontal and vertical 
direction coordinates are set here. 

 

(17) Adding block patterns  

1. Select the     button on the parts box window. 
2. Set the properties in the parts properties display area.  
3. A part is added when it is clicked on the edit window.  
4. To change the properties of a part which has already been added, select the part to be 

edited, and change the properties in the parts properties display area.  
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Fig. 4-23 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Area The display area (whole display area or limited area 
designation) is set here. 

Mode The display mode (line number designation or dot 
designation) is set here. 

Dir 

The display direction is set here.  
(Horizontal, vertical, horizontal & V, vertical & H, top left → 
bottom right, bottom left → top right, top right → bottom left, 
bottom right → top left) 

Interval H, 
Interval V 

The horizontal and vertical intervals (number of lines with the 
line designation or line interval with the dot designation) are 
set here. 

Color Detail The display colors are designated here.  
Up to 256 colors can be designated. 

Left, Top, 
Right, Bottom 

The coordinates (LDC or WC) and the horizontal and vertical 
direction coordinates are set here.  

 

(18) Color detail  

This is used to designate the display colors.  
Up to 256 colors can be designated.  

Fig. 4-24 
 
Pattern Select  

This is used to set the colors 
individually.  
 

Multi Select  
This is used to select and set a range 
of colors. 
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Color Pattern This is where the colors (actually used) which were added 
from the color table are displayed. 

Color Table This is where the colors (1 to 256) of the palette which has 
been set using the data properties is displayed. 

Add This is for adding colors. 
Delete This is for deleting the added colors. 

Step This is for setting the number of colors to be stepped by Color 
Pattern. 

Arrow This is for moving the colors selected by Color Pattern up or 
down. 

 

(19) Adding character patterns  

1. Select the     button on the parts box window.  
2. Set the properties in the parts properties display area.  
3. A part is added when it is clicked on the edit window.  
4. To change the properties of a part which has already been added, select the part to be 

edited, and change the properties in the parts properties display area.  

Fig. 4-25  
 
 
 
 
 
 
 
 
 
 
 

Char Code The character code is input here. ('C': default) 
Rop The drawing mode (Set, Or, And) is set here. 
Color The drawing color (palette No.) is set here. 
BkColor The character background color (palette No.) is set here. 
Font The font size is set here. 

Format The character format (list, character, corner & center) is set 
here. 

Cell H, Cell V The character interval (cell H) and line interval (cell V) are set 
here. 

Left, Top, 
Right, Bottom 

The coordinates (LDC or WC) and the horizontal and vertical 
direction coordinates are set here. 

 

(20) Adding burst patterns  

1. Select the     button on the parts box window.  
2. Set the properties in the parts properties display area.  
3. A part is added when it is clicked on the edit window.  
4. To change the properties of a part which has already been added, select the part to be 

edited, and change the properties in the parts properties display area.  
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Fig. 4-26  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Format 
The display format is set here. 
(Left→right, right→left, center→left/right, left/right→center, 
up→down, down→up, center→up/down, up/down→center) 

Interval The number of lines (0 to 255) to be repeated for the same 
line width is set here. 

Step The line width increment (0 to 255) is set here. 
Color1, 
width1 

The #1 display color (palette No.) and line width (0 to 255) are 
set here. 

Color2, 
width2 

The #2 display color (palette No.) and line width (0 to 255) are 
set here. 

Len H, Len V The horizontal and vertical line lengths are set here.  
When the figures are changed, the line lengths change. 

Left, Top, 
Right, Bottom 

The coordinates (LDC or WC) and the horizontal and vertical 
direction coordinates are set here. 

 

(21) Adding edge marks  

1. Select the     button on the parts box window.  
2. Set the properties in the parts properties display area.  
3. A part is added when it is clicked on the edit window.  
4. To change the properties of a part which has already been added, select the part to be 

edited, and change the properties in the parts properties display area.  

Fig. 4-27  
 
 
 
 
 
 
 

Color The drawing color (palette No.) is set here. 
Rop The drawing mode (Set, Or, And) is set here. 
Width H, 
Width V The horizontal and vertical line widths are set here.  

 
 
 

(22) Adding center marks  

1. Select the     button on the parts box window.  
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2. Set the properties in the parts properties display area.  
3. A part is added when it is clicked on the edit window.  
4. To change the properties of a part which has already been added, select the part to be 

edited, and change the properties in the parts properties display area.  

Fig. 4-28  
 
 
 
 
 
 
 
 

Color The drawing color (palette No.) is set here. 
Width H, 
Width V The horizontal and vertical line widths are set here. 

Len H, Len V The horizontal and vertical line lengths are set here. 
When the figures are changed, the line lengths change. 

 

(23) Saving selected parts  

Selected parts (including the selections of multiple parts) can be saved in a file. 
• Select the [Select Parts Save] menu item on the [File] menu.  

To load selected parts, use the inserting parts function.  
 

(24) File properties  

The file properties (file type, size, properties, etc.) can be displayed.  
• Select the [Property] menu item on the [File] menu.  

 
(25) Inserting parts  

Selected parts which were saved can be loaded.  
• Select the [Insert] menu item on the [Edit] menu.  

 
(26) Displaying the grid  

The positioning grid on the edit window can be displayed.  
• Select the [Grid View] menu item on the [View] menu.  

 
(27) Positioning the grid  

The parts positions can be aligned with the grid.  
• Select the [Grid Positioning] menu item on the [View] menu.  

 

(28) Displaying the full screen  

The edit window on the full screen can be displayed.  
• Select the [Full View] menu item on the [View] menu. 
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4.4 Optional pattern editor  

This section describes how to set the optional pattern data (referred to henceforth as the "optional 
patterns") of the programmable video signal generator (referred to henceforth as the "VG"). The 
program enables optional patterns to be edited in Windows and edited palette data to be sent to the 
VG and executed.  

 
4.4.1 Startup method  

The editor starts up with the sequence editor. (For details, refer to the section on the sequence 
editor.) When the editor is started up, the optional patterns registered in the selected sequence 
list or displayed on the selected source list are loaded.  

 
4.4.2 Window screen and names  

Fig. 4-29 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Editing area  
The source codes (*.mc files) of the optional patterns are created, revised and displayed on 
this screen.  

 
Compile  

This is for compiling the source codes of the optional patterns and creating the optional 
pattern data which is the intermediate language.  

 
Compile screen  

The messages accompanying the compiling operations appear on this screen. 
 
 
4.4.3 Optional pattern data  

This is the data which is created in the form of an intermediate language from compiling the 
source codes of the optional patterns and which can be used by the VG. It is the data that is 
sent to and received from the VG.  

Compile 
screen 

Editing area
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4.4.4 Menus  

(1) [File] menu  
Menu command Function 

Load Loads data from a file. 
Load Sample Loads the sample data from a sample file. 
Save Saves the data in a file. 

Save As Changes the data filename and saves the data in that 
file. 

Execute Executes the display data. 
Properties Displays the file properties. 
Print Prints the display data. 
Exit Option Pattern 
Editor Exits the program. 

 
(2) [Option] menu 

Menu command Function 
Font Changes the font which displays the source codes. 

 
(3) [Help] menu 

Menu command Function 
Contents Displays the help contents. 
Index Enables help topics to be searched. 
About Displays the version information. 

 
4.4.5 Operating procedure  

(1) Creating optional patterns  

1. Write the source codes in the editing area. (Alternatively, load a *.mc file which has 
been created (load the optional source code.) For details on how to create such a file, 
refer to make_opt.txt or the optional pattern creation help.  

 
2. Save the source code which was written in the editing area in the file,  

and proceed with compiling. Select the     button. 

Alternatively, simply press the      button without saving the source code. The 
save dialog box now opens. Unless a new file is involved, the data will be saved in 
the file by overwriting the existing data so press the OK button.  

 
3. Compiling is completed normally when the "Compile OK." message appears on the 

compile screen. The optional pattern language, which is an intermediate language, 
has now been created from the source codes.  
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(2) Changing the font  

The font can be changed. The font change dialog box appears. The new setting is saved 
and used from the next time also. Only the printing font and display font in the editing 
area are affected by this setting.  

• Either select the [Font] menu item on the [Option] menu or select the    button 
from the tool buttons.  

 
(3) Loading data  

The data of a selected file can be loaded.  
The same filename as at startup is retained.  

• Either select the [Load] menu item on the [File] menu or select the    button from 
the tool buttons.  

• The source directory is now displayed. 
 

(4) Loading sample data  

Data can be loaded from the sample file in the sample directory. The same filename as at 
startup is retained.  

• Select the [Load Sample] menu item on the [File] menu. 
• The sample directory is now displayed. 

 
(5) Saving data  

Edited data can be saved in a file while overwriting the existing data in that file. 

• Either select the [Save] menu item on the [File] menu or select the     button from 
the tool buttons.  

• The data is now saved in the source directory. 
 

(6) Saving data as  

A new filename can be created and the data saved in that file. The name on the sequence 
list of the sequence editor is also changed to the new filename.  

• Either select the [Save As] menu item on the [File] menu or select the    button 
from the tool buttons. 

• The source file which has now been created is saved in the source directory which 
was set when the sequence editor was started up. 

 
(7) Executing data  

The data being edited can be sent to the VG and executed.  

• Either select the [Execute] menu item on the [File] menu or select the    button 
from the tool buttons.  
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(8) Printing the display data  

The display data can be printed.  

• Either select the [Print] menu item on the [File] menu or select the     button from 
the tool buttons.  

  
(9) Exiting the program  

The step below is followed to exit the program.  

• Select the [Exit Option Editor] menu item on the [File] menu. 
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4.5 Image converter  

This section describes how to set the image data of the programmable video signal generator (referred 
to henceforth as the "VG"). Using this program, BMP data and JPG data can be converted into VBM 
data in Windows, executed by the VG and saved in files. 

 
4.5.1 Startup method  

Start up the converter from the sequence editor. (For details, refer to the section on the 
sequence editor.) When the converter is started up, the image data registered in the selected 
sequence list or displayed on the selected source list is loaded.  

 
4.5.2 Concerning graphic data  

BMP data:  
An image format (extension *.bmp) often handled in Windows 

 
JPG data:  

Another image format (extension *.jpg) often handled in Windows  
 

VBM data:  
BMP data and JPG data cannot be used by the VG. It must be changed into data which is 
supported by the VG.  
The image conversion program converts the BMP data and JPG data into VBM data 
(extension *.vbm) supported by the VG. 
Only full colors are supported. Use any other number of colors after first converting them 
into full colors. 

 
4.5.3 Window screen and names  

 
Fig. 4-30 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Image Size 

Filename

Image data display 

Image Color Count
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Filename 

This is where the name of the file containing the image data now displayed is indicated. 
 

Image data display area 
This is where the selected image data is displayed. 
 

Image type 
This is where the type (VBM, BMP or JPG) of the image data now displayed is indicated. 
 

Image size 
This is where the size of the image data now displayed is indicated. 
 

Color count 
This is where the number of colors of the image data now displayed is indicated. 

 
 

4.5.4 Menus  
(1) [File] menu 

Menu command Function 
Load Loads data from a file. 
Load Sample Loads the sample data from a sample file. 
Save Saves the data in a file. 

Save As Changes the data filename and saves the data in that 
file. 

Execute Executes the display data. 
Properties Displays the file properties. 
Print Prints the display data. 
Exit image Converter Exits the program. 

 
(2) [Help] menu 

Menu command Function 
Contents Displays the help contents. 
Index Enables help topics to be searched. 
About Displays the version information.  

 
4.5.5 Operating procedure  

(1) Converting data  

Load the data from the BMP files, JPG files or VBM files or load the sample data. The 
data in the BMP files and JPG files will have been converted into VBM data by the time 
it is displayed on the image converter.  
When a BMP data file or JPG data file is loaded by the image converter, the data is first 
converted into VBM data before it is displayed. When it is saved as it stands, it will be 
saved as a VBM data file.  
 

(2) Loading data  

The selected image file can be converted into VBM data and loaded. The same filename 
as at startup is retained.  

• Either select the [Load] menu item on the [File] menu or select the    button from 
the tool buttons. 

• The source directory is now displayed. 
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(3) Loading sample data  

Image data can be loaded from the sample file in the sample directory. The same 
filename as at startup is retained.  

• Select the [Load Sample] menu item on the [File] menu. 
• The sample directory is now displayed. 

 

(4) Saving data  

This is for saving the converted data in the file while overwriting the existing data in 
that file.  
The data is saved in a VBM data file (with the *.vbm extension).  

• Either select the [Save] menu item on the [File] menu or select the      from the 
tool buttons. 

• The data is now saved in the source directory. 
 

(5) Saving data as  

A new filename can be created and the data saved in that file. The name on the sequence 
list of the sequence editor is not changed to the new filename.  

• Either select the [Save As] menu item on the [File] menu or select the    button 
from the tool buttons. 

• The source file which has now been created is saved in the source directory which 
was set when the sequence editor was started up. 

 
(6) Executing data  

The image data displayed can be sent to the VG and executed. 

• Either select the [Execute] menu item on the [File] menu or select the      button 
from the tool buttons. 

 
(7) Printing display data 

The display data can be printed. 

• Either select the [Print] menu item on the [File] menu or select the     button from 
the tool buttons. 

 
(8) Exiting the program 

The step below is followed to exit the program. 

• Select the [Exit Image Converter] menu item on the [File] menu. 
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4.6 Palette set editor 

This sections describes how to set the palette set data (referred to henceforth as "palette data") of the 
programmable video signal generator (referred to henceforth as the "VG"). VG palette editing is 
possible in Windows using this program. 

 
4.6.1 Start Up method 

Start up the palette set editor from the sequence editor. (For details, refer to the section on the 
sequence editor.) When the editor is started up, the palette data registered in the selected 
sequence list or displayed on the selected source list is loaded. 

 
4.6.2 Window screen and names 

Fig. 4-31 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Data grid 
This is for setting the palette RGB data.  

 
Color setting (Col) 

The colors which are to be shown by the data of the RGB cell in the same row are 
displayed here. When the cell is clicked, the color setting dialog box appears, and the 
color data selected in the dialog box is set to the RGB cell in the same row.  

 
Window Color 

This is for setting the background color of the VG's window. 
 
4.6.3 Data setting ranges 

The RGB data setting range is 0 to 255. A value from 0 to 255 is also set for the window 
color RGB data. 

Window Color 

Color Set Col 

Data grid 



 
SP-8022-2 Help (Instruction Manual) 

 4-59 

 
4.6.4 Menus 

(1) [File] menu  
Menu command Function 

Load Loads data from a file. 
Load Sample Loads the sample data from a file. 
Save Saves the data in a file. 

Save As Changes the data filename and saves the data in that 
file. 

Execute Executes the display data. 
Properties Displays the file properties. 
Print Prints the display data. 
Exit Palette Set Editor Exits the program. 

 

(2) [Edit] menu 
Menu command Function 

Color Set 

Captures the color data values from the Windows 
[Color setting] dialog box. Move the cursor to the cell 
with the data to be changed, and select Color Set. 
The Windows color setting dialog box now appears. 
Select the color to which it is to be changed. The color 
indicated on the Col display and the color data of the 
selected cell are changed. 

Data Change 

Selects the data line (RGB) to which the change is to 
be made when any of the [Color] menu commands 
are used. These commands cannot be used if Data 
Change has not been selected. 

Toggle All Select/ 
No Select 

Sets all the RGB data to the selected status (the 
characters turn a dark blue color) if no data has been 
selected; releases the selection status if there is a 
data line (RGB) which has been selected. 

 

(3) [Color] menu 

To select any [Color] menu commands except All Clear, select [Toggle All Select/No 
Select] on the [Edit] menu. (First, click the RGB title button on the grid, and select the 
row in which the data is to be set.)  

Menu command Function 

Positive Sets the data for the selected data line (RGB) to a positive 
pattern. 

Negative Sets the data for the selected data line (RGB) to a negative 
pattern. 

Posterize Sets the data for the selected data line (RGB) to a gradation 
up to 256 colors. 

Gamma Sets the data for the selected data line (RGB) to gamma 
data. 

Liner Sets the data for the selected data line (RGB) by applying 
an equation (y= ax + b) expressing a straight line. 

Liner 2 
Sets the data for the selected data line (RGB) to data which 
is incremented or decremented by the difference between 
two points designated on the plane. 

Fill Sets the data for the selected data line (RGB) to the same 
data which has been set. 

All Clear Clears all the data to zero. 
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(4) [Help menu] 
Menu command Function 
Contents Displays the help contents. 
Index Enables help topics to be searched. 
About Displays the version information.  

 
4.6.5 Operating procedure 

(1) Creating data  

Set the 8-bit RGB color data (0 to 255) from No. 0 to 255 on the grid. After either 
selecting [Toggle All Select/No Select] on the [Edit] menu or clicking R, G and B of 
[RGB title Row] to set [RGB Data Grid] to the selection status, select a command from 
the [Color] menu, and input the data. 
 

(2) Loading data 

The data of the selected file can be loaded. The same filename as at startup is retained. 

• Either select the [Load] menu item on the [File] menu or select the     buttons 
from the tool buttons. 

• The source directory is now displayed. 
 

(3) Loading sample data  

Data can be loaded from the sample file in the sample directory.  

• Select the [Load Sample] menu item on the [File] menu. 
• The sample directory is now displayed. 
 

(4) Saving data  

The edited data can be saved in a file while overwriting the existing data in that file.  

• Either select the [Save] menu item on the [File] menu or select the     button from 
the tool buttons. 

• The data is now saved in the source directory. 
 

(5) Saving data as 

A new filename can be created and the data saved in that file. The name on the sequence 
list of the sequence editor is also changed to the new filename. The source file created is 
saved in the source directory which was set when the sequence editor was started up.  

• Either select the [Save As] menu item on the [File] menu or select the     button 
from the tool buttons. 

• The source file which has now been created is saved in the source directory which 
was set when the sequence editor was started up. 

 
 

(6) Executing data  

The data being edited can be sent to the VG and executed.  

• Either select the [Execute] menu item on the [File] menu or select the     button 
from the tool buttons. 
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(7) Printing display data  

The display data can be printed.  

• Either select the [Print] menu item on the [File] menu or select the     button from 
the tool buttons. 

 
(8) Exiting the program  

The step below is followed to exit the program.  

• Select the [Exit Palette Set Editor] menu item on the [File] menu. 
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4.7 Action editor  

This section describes how to set the action data of the programmable video signal generator (referred 
to henceforth as the "VG"). This program enables VG action data to be edited in Windows and edited 
action data to be sent to the VG and executed. 

 
4.7.1 Startup method  

Start up the action editor from the sequence editor. (For details, refer to the section on the 
sequence editor.)  
When the editor is started up, the action data registered on the selected sequence list or 
displayed on the selected source list is loaded.  
 
 
Window screen and name  

Fig. 4-32  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Action setting screen  

The action data is set on this screen. 

Action setting 
screen 
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4.7.2 Data setting ranges 

Action Interval  0 to 9999 V 
 ON/OFF 
PalNo. 1 0 to 255 
PalNo. 2 0 to 255 Flicker 

PalNo. (off) 0 to 255 
Window Flicker  ON/OFF  

Level 1 0.00 to 1.00V 
Level 2 0.00 to 1.00V Video Level 
Sep -0.50 to 5.00V 
 ON/OFF Window Level Step -128 to 127 
 ON/OFF 

Direction Height, Width, Left, Right, Up, Down, Left Up,
Left Down, Right Up, Right Down Window Scroll 

Step 0 to 255 dots 
 ON/OFF 
PalNo. 1 0 to 255 
PalNo. 2 0 to 255 Palette Scroll 

Step -128 to 127 
 ON/OFF 
Direction H&V, H...H → V, V...V → H 
H-Start 0 to 8184 Note 1) 
H-End  0 to 8184 Note 1) 
H-Step -8184 to 8184 dots Note1) 
V-Start 0 to 4095 
V-End 0 to 4095 
V-Step -4095 to 4095 dots 
H-Offset 0 to 8184 

Disp Position 

HO-Max 0 to 8184 
Note 1: Only multiples of 8 can be input as data. Otherwise, the data will be rounded up or 

rounded down. 
 
4.7.3 Menus 

(1) [File] menu 
Menu command Function 

Load Loads data from a file. 
Load Sample Loads the sample data from a file. 
Save Saves the data in a file. 
Save As Changes the data filename and saves the data in that file.
Execute Executes the display data. 
Properties Displays the file properties. 
Print Prints the display data. 
Exit Action Editor Exits the program. 

 
(2) [Help] menu 

Menu command Function 
Contents Displays the help contents. 
Index Enables help topics to be searched. 
About Displays the version information.  
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4.7.4 Operating procedure 

(1) Selecting the action type  

Data for no other action type can be set when the "No Action" is selected for the action 
type. To set the data, select the action type of the setting items. The data items which can 
be set are now enabled.  

No Action The action data is not set. 
 

Flicker This causes the palettes from PalNo. 1 to PalNo. 2 to 
flicker at the designated intervals (V number). PalNo. (off) 
selects the palettes when the display is OFF.  
 

Window Flicker The window display is turned ON and OFF at the 
designated intervals (V number).  
 

Video Level This causes the video (DAC) output level to be changed 
from Level 1 to Level 2 at the designated step and at the 
designated intervals (V number). 
 

Window Level This causes the window level to be changed at the 
designated step and at the designated intervals (V 
number). The window level is changed by the palette set 
data. It changes at a step from 0 to 255 based on the 
window color of the palette set data. 
 

Window Scroll This causes the window to move in the designated 
direction at the designated step and at the designated 
intervals (V number). 
 

Palette Scroll This causes the palettes from PalNo. 1 to PalNo. 2 to be 
scrolled (rotated) at the designated step and at the 
designated intervals (V number).  
 

Disp Position This causes the display position to move in the designated 
direction at the designated step and at the designated 
intervals (V number). 

 
1. When H&V is selected: 

The display position is moved at the designated step from Start to End for both H 
and V. Designate V_Step=0 if it is to be moved only horizontally; designate 
H_Step=0 if it is to be moved only vertically. 

2. When H H is selected: 
The display position is repeatedly moved at the designated step from H_Start to 
H_End horizontally. 

3. When V V  is selected: 
The display position is repeatedly moved at the designated step from V_Start to 
V_End vertically.  
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Operation is as follows when H_Offset is not equal to 0 for both (2) and (3). 
After (2) or (3) is executed once. H_Offset is added only to the horizontal position of the 
display start position, and (2) or (3) is repeated.  
When the value which is added to the horizontal position of the display start position 
reaches HO_Max, it is reset to 0. 

 
(2) Loading data  

The data of the selected file can be loaded. 
The same filename as at startup is retained. 

• Either select the [Load] menu item on the [File] menu or select the    button from 
the tool buttons. 

• The source directory is now displayed. 
 

(3) Loading sample data  

Data can be loaded from the sample file in the sample directory. The same filename as at 
startup is retained. 

• Select the [Load Sample] menu item on the [File] menu. 
• The sample directory is now displayed. 
 

(4) Saving data  

The edited data can be saved in a file while overwriting the existing data in that file. 

• Either select the [Save] menu item on the [File] menu or select the     button from 
the tool buttons. 

• The data is now saved in the source directory. 
 

(5) Saving data as  

A new filename can be created and the data saved in that file. The name on the sequence 
list of the sequence editor is also changed to the new filename. The source file created is 
saved in the source directory which was set when the sequence editor was started up. 

• Either select the [Save As] menu item on the [File] menu or select the     from the 
tool button. 

• The source file created is saved in the source directory which was set when the 
sequence editor was started up. 

 
(6) Printing display data  

The data which is being edited can be printed. 

• Either select the [Print] menu item on the [File] menu or select the     button from 
the tool buttons. 

 
(7) Executing data  

The data being edited can be sent to the VG and executed. 

• Either select the [Execute] menu item on the [File] menu or select the     button 
from the tool buttons. 
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(8) Exiting the program  

The step below is followed to exit the program. 

• Select the [Exit Action Editor] menu item on the [File] menu. 
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4.8 DDC editor 

How to set the DDC data of the programmable video signal generator (referred to henceforth as the 
"VG") is described in this section. This program enables the DDC data of the monitor that supports 
DDC to be sent, received and edited in Windows. 

 
4.8.1 Startup method 

In Windows 98 or 2000 or XP, select [Start] - [Programs] - [SP-8022-2] - [DDC Editor], and 
start [DDC Editor]. 
The DDC editor starts up with nothing displayed on the screen. 

 
4.8.2 Window screen and names 

Fig. 4-33 

 
 
 

 
DispMode selector buttons 
These are used to select the GUI display mode and binary display mode. 

• GUI display mode 

The data is displayed on the screen in an easy to read graphical format suitable for the 
block type concerned. For block types which are not supported, the data is displayed in a 
binary format. 

• Binary display mode 

The data is displayed in a 128-byte binary format. 

 

Display 
mode 
selector 
buttons 

Block type list 
Checksum 

Data display 
screen 

Automatic 
calculation of 
checksum 

Checksum
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Digital and analog selector buttons 
These are used to switch between digital and analog. 

Block type list 
A list of the block types appears here, and the block number and block type (block code of 
first byte) are displayed for one block. 

Data display screen 
The data of the block selected on the block type list at the left is displayed here. 

Checksum 
The checksum value is displayed here. 

The checksum is the value of the last byte in the block. 

When "Auto checksum" is checked, the checksum is automatically updated each time the 
data is changed. 

Auto checksum (automatic calculation of checksum) 
When this is checked, the checksum value is automatically updated each time the data is 
changed. 

 
4.8.3 Menus 

(1) [File] menu 
Menu command Function 

New Creates a new data file. 
Open Opens a file. 
Load One-Block Loads the data from a file in block increments. 
Save Saves the data in a file. 
Save As Changes the data filename and saves the data in that file. 
Close Closes a file. 
Properties Displays the file properties. 
Print Prints the display data. 
Exit DDC Editor Exits the program. 

 
(2) [Edit] menu 

Menu command Function 
Insert-up Block Forward inserts a new block. 
Insert-down Block Backward inserts a new block. 
Delete Block Deletes a block. 
Copy Block Copies a block. 
Move Block Moves a block. 
Change Block Type Changes the block type. 

 
(3) [VG] menu 

Menu command Function 
Send to VG Sends the DDC data being edited to the monitor. 
Receive from VG Receives the DDC data from the monitor. 
Verify Compares the contents of the monitor ROM with the DDC 

data being edited. 
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(4)  [Option] menu 

Menu command Function 

Binary Byte (1 byte) Displays the data that is delimited byte by byte when the data 
is displayed in the binary format. 

binary Short (2 byte) Displays the data that is delimited every other byte when the 
data is displayed in the binary format. 

Binary Long (4 byte) Displays the data that is delimited every 4 bytes when the 
data is displayed in the binary format. 

DDC2B Communicates using DDC2B. 
DDC1 Communicates using DDC1. 

 
(5)  [Help] menu 

Menu command Function 
Contents Displays the help contents. 
Index Enables help topics to be searched. 
About Displays the version information. 

 
4.8.4 Operating procedure 

(1) Creating new DDC data 
1. Click [New] on the [File] menu. 

The dialog box for selecting the number of blocks to be created (ROM size of 
monitor) now appears. 

2. Select the number of blocks to be created in accordance with the ROM size of the 
monitor, and press the [OK] button. The specified number of blocks are created. The 
initial value for all the data is 0. 

 
*  The number of blocks can be changed even after new data has been created 

 
(2) Opening a file 

A file which has been saved can be opened and the DDC data loaded into it. 

1. Select the [Open] menu item on the [File] menu or select the  button from 
among the tool buttons. 

2. Select the file, and press the [OK] button. 

3. The selected file is now opened, and the DDC data is displayed. 
 

(3) Loading data in a specific block from a file 
DDC data in a specified block can be loaded from a file. 

1. Select the block whose DDC data is to be loaded. 

2. Click [Load One-Block] on the [File] menu. 

The file selection dialog box appears. 

3. Select the file, and press the [OK] button. 

Next, the block selection dialog box appears. 

4. Select the block whose data is to be loaded, and press the [OK] button. 

5. The DDC data in the selected block is loaded and displayed. 
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(4) Editing the DDC data 

The block type is decided on first, and then the data is edited. 

1. Decide on the block type. 

Select the block to be edited, and then click [Change Block Type] on the [Edit] menu. 

The block type selection dialog box now appears. 

Select the target block type, and press the [OK] button. 

2. In the GUI display mode, the display format is switched depending on the block 
type. 

In the binary display mode, 128 bytes are dumped and displayed. 

For details of the data, refer to the reference documentation. 

 
(5) Saving a file 

The data displayed on the screen can be saved in a file. 

1. When the [Save] menu item is selected on the [File] menu or the  button is 
selected from among the tool buttons, the data in the selected file will be overwritten 
and the data displayed on the screen will be saved in its place. 

2. When the [Save As] menu item is selected on the [File] menu or the  button 
is selected from among the tool buttons, the file selection dialog box appears. 
Input the filename, and press the [OK] button. The displayed characters are saved in 
the new file. 

 
(6) Sending the data to the monitor 

DDC data can be saved in the monitor ROM. 

1. When the [Send] menu item is selected on the [VG] menu or the  button is 
selected from among the tool buttons, the send data dialog box appears. 

2. Select DDC1 or DDC2B and decide on the numbers of the blocks to be sent (from 
block #0 to the selected block #). 

When the [Fix Monitor] button is pressed, communication with the monitor is 
initiated, and the data can be matched with the maximum size of the monitor ROM. 

3. When the [OK] button is pressed, the DDC data is sent. 
 

(7) Receiving the data from the monitor 
DDC data can be received from the monitor ROM. 

1. Wen the [Receive] menu item is selected on the [VG] menu or the  button 
is selected from among the tool buttons, the receive data dialog box appears. 

2. Select DDC1 or DDC2B and decide on the numbers of the blocks to be received 
(from block #0 to the selected block #). 
When the [OK] button is pressed, the DDC data is received. 

3. The received DDC data now appears on the screen. 
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(8) Verifying the data being edited against the monitor ROM data 
DDC data can be loaded from the monitor ROM, and compared with the DDC data 
which is being edited. 

1. When the [Verify] menu item is selected on the [VG] menu or the  button 
is selected from among the tool buttons, the verify data dialog box appears. 

2. Select DDC1 or DDC2B and decide on the numbers of the blocks to be compared 
(from block #0 to the selected block #) and the mask setting. 

The mask setting can be selected only for Basic EDID product codes and serial 
numbers. When it is checked, its items are not compared. 

When the [Fix Monitor] button is pressed, communication with the monitor is 
initiated, and the data can be matched with the maximum size of the monitor ROM. 

When the [OK] button is pressed, the DDC data verification is commenced. 

 
(9) Printing the DDC data 

The DDC data displayed can be printed in a binary format. 

1. Select the [Print] menu item on the [File] menu or select the  button from 
among the tool buttons. 

2. The print dialog box now appears. Set here the numbers of the blocks to be printed 
and the margins. 

3. When the [OK] button is pressed, the DDC data displayed is printed in a binary 
format. 

4. To change the printer which has been set, select the Set Printer... button. 

5. The printer setting dialog box now appears. 

Proceed with the settings. For details on the operating procedure of this dialog box, refer 
to the instructions for Windows or the printer used. 

 
4.8.5 Block operations 

(1) Forward inserting a block 
Click the block immediately below the position where the block is to be inserted. 

Click [Insert-up Block] on the [Edit] menu. 

(2) Backward inserting a block 
Click the block immediately above the position where the block is to be inserted. 

Click [Insert-down Block] on the [Edit] menu. 

(3) Deleting a block 
Click the block to be deleted. 

Click [Delete Block] on the [Edit] menu. 

(4) Copying a block 
Click the block to be copied. 

Click [Copy Block] on the [Edit] menu. 

(5) Moving a block 
Click the block to be moved. 
Click [Move Block] on the [Edit] menu. 
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(6) Changing the block type 
Click the block whose type is to be changed. 

Click [Change Block Type] on the [Edit] menu. 
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4.9 Execution program used for manufacture  

This section describes the execution program used for manufacturing and designed to run on a 
programmable video signal generator (referred to henceforth as the "VG"). Using the sequence files 
created, this program sends the data to the VG and executes it through key operations. Create the data 
using the sequence editor and other editors.  
 
4.9.1 Window screen and names 

Fig. 4-33  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Func window 
One sequence file can be registered in each function key, F I through F12, making a total 
of 12 files altogether which can be registered.  
Files are registered in the function keys using [Func-Key Assign] on the [Option] menu.  
By registering the files in the function keys, the sequence files can thereafter be switched 
simply by pressing the function keys.  

 
Timing window  

Displayed on this window are the name of the timing data, dot clock signal, horizontal and 
vertical frequencies and name of the pattern currently being executed.  

 
 
ON/OFF windows  

Displayed on these windows are the ON/OFF statuses of the outputs of the R/G/B signals 
and HS/VS/CS signals currently being executed. Values can also be changed by pressing 
the shortcut keys. The shortcut keys are changed using [Key Assign] on the [Option] 
menu. 

 
NEGA/POSI windows  

Displayed on these windows are the NEGA/POSI statuses of the output of the HS/VS/CS 
signals currently being executed. Values can also be changed by pressing the shortcut 

Func window

ON/OFF 
windows 

NEGA/POSI windows 

DEC execute 
button 

INC execute 
button 

Timing 
window 
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keys.  
The shortcut keys are changed using [Key Assign] on the [Option] menu.  

 
INC execute button  

This is for incrementing the sequential No. being executed by l, and executing the next 
sequential No.  
It is equivalent to pressing the → key.  

 
DEC execute button  

This is for decrementing the sequential No. being executed by l, and executing the 
previous sequential No.  
It is equivalent to pressing the ← key.  

 
4.9.2 Menus  

(1) [File] menu  
Menu command Function 

Exit Sequence Execute Exits the program. 
 

(2) [View] menu  
Menu command Function 

Func window  Window on which the function keys are registered 

Timing window Window on which the timing data being executed is 
displayed  

ON/OFF window  Window on which the ON/OFF status being 
executed is displayed 

NEGA/POSI window Window on which the NEGA/POSI status being 
executed is displayed 

 
(3) [Execute] menu  

Menu command Function 

INC Increments the sequential No. being executed and 
executes the next No. 

DEC Decrements the sequential being executed and 
executes the previous No.  

 
(4) [Func] menu  

Enables sequence files to be selected from already registered function keys. 
 

(5) [ON/OFF] menu  

Enables the ON/OFF status of the signal output being executed to be set.  
 

 

(6) [NEGA/POSI] menu  

Enables the NEGA/POSI status of the data being executed to be set.  
 

(7) [Option] menu  

Func Key Assign  Registers the sequence files in the F1 through F12 
keys. 

Key Assign  Sets the shortcut keys for the ON/OFF window and 
NEGA/POSI window. 
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(8) [Help] menu  

Contents Displays help. 
Index Enables help topics to be searched. 
About Displays the version information. 

 
4.9.3 Operating procedure 

(1) Startup for the first time after installation  

1. The sequence files must be registered in the function keys.  
The registration sequence is as follows:  
Select [Func-Key Assign] on the [Option] menu.  
Register the sequence files in function keys F1 through F12.  

2. Select one of the function keys F1 through F12 to open the sequence file. Sequential 
No.1 is executed as soon as the sequence file is opened. The information on the data 
being executed is displayed on the Timing window, ON/OFF window and 
NEGA/POSI window.  

3. Select the INC or DEC execute button to execute the sequential No. thus selected.  
 

(2) Startup for the second and subsequent times after installation  

1. The sequence file which was opened last with the last startup is displayed. The 
sequential No. executed last is executed.  

2. Select the INC or DEC execute button to execute the sequential No. thus selected.  
 

(3) Exiting the program  

Either of the following methods can be used to exit the manufacture execution program.  
• Select exit on the [File] menu.  
• Select close on the control menu.  

 

(4) Execution  

When the → key is pressed, the sequential No. currently being executed is incremented 
by one and the sequential No. thus selected is executed.  
When the ← key is pressed, the sequential No. currently being executed is decremented 
by one and the sequential No. thus selected is executed.  
The name of the timing data. dot clock signal, horizontal and vertical frequencies and 
name of the pattern currently being executed are displayed on the Timing window. 
The ON/OFF statuses of the output of the R/G/B signals and HS/VS/CS signals 
currently being executed are displayed on the ON/OFF window.  
Output statuses can also be changed by pressing the shortcut keys.  
The NEGA/POSI statuses of the output of the HS/VS/CS signals currently being 
executed are displayed on the NEGA/POSI window.  
Output statuses can also be changed by pressing the shortcut keys.  

 
(5) Setting the function keys  

Sequence files can be registered in the F1 through F12 keys.  
1. Click [Func-Key Assign] on the [Option] menu.  
2. The function key setting dialog box is displayed. 
3. Register the sequence files in the F1 through F12 keys.  
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(6) Setting the shortcut keys  

This is for setting the shortcut keys for the ON/OFF and NEGA/POSI statuses of the 
output of the R/G/B and HS/VS/CS signals.  
l. Click [Key Assign] on the [Option] menu.  
2. The shortcut key setting dialog box is displayed. 
3. Register the shortcut key for each item. 
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CHAPTER 5 
HOW TO CREATE USER OPTIONAL PATTERNS  

Using the SP-8022-2, the VG-862 can create user optional patterns. 
The following aspects of the procedures involved are described in this chapter.  
 

1. User optional pattern creation/execution procedure 
2. Concerning the VG-862 hardware  
3. Description of syntax 
4. Function reference 

 
5.1 User optional pattern creation / execution procedure  

User optional patterns are represented by the source codes which are described using a syntax 
similar to the one used with the C programming language. This data is compiled by SP-8022 
and registered in files in the form of an intermediate language. 
 
(1) Creating the source codes of user optional patterns  

Source codes are described using a syntax similar to the one used with the C programming 
language.  
For details on the syntax, refer to "Description of syntax" in 5-3.  
Use the Windows standard "Notepad" or another text editor to create the source codes.  
The extension for the source codes is ".mc."  

 
(2) Compiling source codes of user optional patterns  

Start [Optedit] from [SeqEdit] of SP-8022 (by selecting OptionPattern with Edit:Newdata), 
and click the Load button to load the source codes (.mc) which have been created. Next, 
click the Compile button to proceed with the compiling. An OK status is indicated if the 
"Compile OK" message appears. If there is an error, revise the source codes, and repeat 
the above steps.  

 
(3) Executing the user optional patterns in the VG-862  

If "Compile OK" is displayed in step (2), the user optional patterns can be executed by the 
VG-862 by clicking the Execute button.  
Note: The maximum size of the data for one user optional pattern which can be executed 
is 64KB.  

 
5.2 Concerning the VG-862 hardware  

This section describes the VRAM (video memory) and LUT (palette) of the VG-862. The 
VG-862 features a 32-bit SDRAM. 

 
(1) 32-bit VRAM (for displays in 16.77 million colors) 

This video memory has a size of 8K (horizontal) x 8K (vertical) x 32 bits (depth), and it 
provides displays in 16.77 million colors. The horizontal and vertical sizes displayed 
differ depending on the horizontal and vertical timing data. Optional patterns are 
displayed with 256 colors using this SDRAM and the LUT. 
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(2) Concerning the coordinate system  

Either the logical device coordinate system (LDC) or world coordinate system (WC) can 
be used.  
LDC: In this coordinate system, the origin point (org_x.org_y) is (0,0), and one pixel of 
the video memory serves as one unit.  
WC: In this coordinate system which is not dependent on a device, the origin point 
(org_x,org_y) is (0,0), and the (size_x-I ,size_y-I ) coordinates from the origin point are 
expressed as ( 10000, 10000).  

 
LDC coordinate system WC coordinate system 

 
 
 
 
 
 
 
 
 
 
 
 

LDC and WC are set using the g8_LdcWc() function. (LDC is the default.)  
 
* (size_x,size_y) are changed by the (h_disp,v_disp) of the timing data. They can also be 

changed when the pattern data is executed.  
With the WC coordinate system, pattern data which is not dependent on this display size 
can be created.  

 
5.3 Description of syntax  

Before they are executed, user optional patterns are interpreted using a language processing 
system (MX interpreter) which has a syntax similar to the one used with the C programming 
language.  
Outlined below are the differences from the C programming language.  
 
(1) Functions deleted from the C programming language  

The following functions of the C programming language are not available.  
 

• Preprocessor functions  
Preprocessor commands starting with "#" (such as #define and #include) cannot be 
used. 

• Structures, unions, bit fields  

• Pointers  
The pointers cannot be used. However, the "&" operator for designating "reference" 
can be used as the argument of functions. 

• Arrays with two or more dimensions (only 1-dimensional arrays may be used)  

• Type definition functions (typedef)  

size-x

size-y

size-x

size-y

(0,0)=(org_x,org_y) (0,0)=(org_x,org_y) 

(size_x-I , size_y-I) ( 10000, 10000) 
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• "const", "volatile" modifiers  

• Object size (sizeof () ) 

• Type cast designation  
Type conversion is done automatically. 

• Register variables 
"register" cannot be designated. "static" can be designated as the declaration of the 
memory class inside functions. 

"auto" cannot be designated expressly. If "static" is not designated, "auto" will be 
designated instead. 

• "extern" and "static" declarations outside functions  
Since, as a general rule, one source text serves as one program, it is not possible to use 
either "extern" declarations or "static" declarations outside functions. 

• Argument definitions in conventional formats  
For instance, arguments cannot be written in the following way. 

int Func (aa,bb)  
int aa;  
char bb;  
{  

….. 
}  

 
Instead, arguments must be written as follows.  
 

int Func (int aa, char bb)  
{  

….. 
}  
 

• Variable arguments (*…*)  
Only the number which has been designated by the function declaration can be the 
number of function arguments, and no omissions are allowed. In other words, the 
number of arguments must match for function declarations and calls. 

• Initialization for declaration of automatic variables  
Initialization can be described in the same way as in C programming in declarations of 
variables outside functions and of variables which were used to designate "static" 
inside functions. 

int aa=1;  /* OK */  
int Func ()  
{  

static int bb = 2;  /* OK */ 
int     cc = 3;  /* Error */  
….. 

}  
 

• Increment, decrement operators (*++*, *--*)  

• Arithmetic substitution (*+=*, -=, **=*, etc.)  
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• Conditional expressions (?:) 

 
(2) Differences from the C programming  

• Comments  
Comments are written using comment /* */ or /$ $/. Comments can be contained 
(nesting is possible) inside other comments. 

• Reference  
Pointers cannot be used with the MX interpreter. Although pointer type arguments 
were used in C programming when functions of multiple values were to be returned to 
the call side or array data was to be transferred, "reference" is used by the MX. This is 
the same as reference in C++, and it can be used only as a function argument. 

(Reference type variables cannot be declared, and neither can the & reference operator 
be used in regular expressions.) 

An example of a function using reference is shown below. 

 
Int Func (int&aa, char&bb [ ] )  
{ 

aa = 100;  
bb[0] = A;  
bb[1] = B;  
return (200);  

}  
 

int main () 
{  

int     x,r; 
char    y[2]; 

r = Func( &x, &y );  
/* r is 200, x is 100, y[0] is *A*, and y[1] is *B* */ 

}  
 

Literal character strings can be used for arguments as the "char" array reference.  
 
int StrLen(char&str [ ] ) 
{ 

int cnt;  
for (cnt = 0; str[cnt]; cnt = cnt + 1); 
return (cnt);   

}  
 
int main ()  
{  

int len;  
len = StrLen("abcdefg");  

} 
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• Function declarations  

Functions created by the user must always be declared before they are called. (Built-in 
functions need not be declared in the source text.) A function is declared either by 
declaring its prototype or by defining its function body. For instance, writing in the 
manner shown below will result in an error.  

int main()  
{  

sub();/$ An error results since neither the definition nor declaration has been 
made.$/  

}  
 
int sub()  
{  

.….  
} 
 

The error is avoided by first defining the function to be called, as shown below.  

int sub()  
{  

.….  
}  
 
int main()  
{  

sub(); /* OK since the function has already been defined. */  
}  
 

Alternatively, the error is avoided by making a prototype declaration as follows.  

Int sub(); /$ Prototype declaration $/  
Int main()  
{  

sub(); /$ OK since the declaration has already been made. $/  
}  
 
int sub()  
{  

.…. 
} 
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• Operation of signed and unsigned integers  

In C programming, when operations are performed between signed integers and 
unsigned integers, signed integers are treated as if they were unsigned. With the MX 
interpreter, however, they are performed in such a way that the expressed values are 
saved as far as possible. Shown below is an example where this difference is present. 

int foo( )  
{  

int          i;  
unsigned int  u;  

i=-1;  
u= 1;  
if ( i < u ) {  

<This is executed by the MX interpreter.>  
} else {  

<This is executed by the C programming language.>  
}  

}  
 

(3) Other specifications  

"int" is identical to "long."  
The maximum number of cases in a switch statement is 127.  
The maximum size of the code part and data part of an execute object after compiling is 
64KB for each. The data part size is the total of the maximum sizes of the static variables 
and of the stack consumed during execution. The stack is consumed by the automatic 
variables within the functions when the functions are called. A dedicated stack different 
from the data stack is used for the return addresses from the functions.  
The maximum number of levels in the function call hierarchy is 64.  
With the MX interpreter as with the C programming language, there is a danger that other 
data will be destroyed by accessing outside the declaration range of the array. However, 
since a different stack is used for the return addresses of the functions, overrunning will 
not be caused by the destruction of return addresses. Further, a check is conducted to 
verify whether these addresses are inside the data part area so that other areas of the 
system will not be destroyed.  
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5.4 Function reference  

The functions are grouped together as follows.  
 
Coordinate system setting functions  

• g8_LdcWc  : Used to set LDC or WC coordinate system. 
• g8_cliparea : Used to set the clip area.  
• g8_clip_  : Used to set the clip ON or OFF. 

 
8-bit VRAM graphics functions  

• g8_allclr  : Used to clear all the graphic planes. 
• g8_clr  : Used to clear the screen. 
• g8_pset  : Used to draw dots. 
• g8_line  : Used to draw lines. 
• g8_sqre  : Used to draw squares (or rectangles). 
• g8_sqpa  : Used to draw and fill squares (or rectangles). 
• g8_tripa  : Used to draw and fill triangles. 
• g8_crcl  : Used to draw circles. 
• g8_crclpa  : Used to draw and fill circles. 
• g8_elps  : Used to draw ellipses. 
• g8_elpspa  : Used to draw and fill ellipses. 
• g8_elps2  : Used to draw ellipses. 
• g8_elpspa2  : Used to draw and fill ellipses. 
• g8_bitblt2  : Used to copy areas 2 (copy in graphics planes). 
• g8_putc  : Used to draw characters. 
• g8_puts  : Used to draw character strings. 

 
LUT setting functions.  

• opt_setcolor  : Used to set LUT colors.  
• opt_setcolor_liner  : Used to set LUT colors (white linear)  
• opt_setcolor_default  : Used to set LUT colors (default).  
• opt_setcolor_256  : Used to set LUT colors (256 colors).  
• opt_setwndcolor : Used to set the window color.  

 
Display-related functions   

• vs_InqDispSize  : Used to inquire about the display size. 
• vs_InqStat  : Used to inquire about the status. 

 
Window setting functions  

• vs_InitWindow  : Used to initialize the window. 
• vs_AddWindow  : Used to set the window data. 
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Pattern drawing functions  

• ptn_char  : Used to draw character patterns.  
• ptn_cross  : Used to draw crosshatch patterns.  
• ptn_dot  : Used to draw dot patterns.  
• ptn Juuji  : Used to draw cross-shaped patterns.  
• ptn_waku  : Used to draw frame patterns.  
• ptn_block  : Used to draw block patterns.  
• ptn_burst  : Used to draw burst patterns. 

 
Other standard functions  

The following functions are compatible with the "clib" standard libraries.  

• acos : double acos (double) 
• asin : double asin (double) 
• atan : double atan (double)  
• atan2 : double atan2 (double x, double y)  
• atof : double atof (char *)  
• atoi : int atoi (char *)  
• cos : double cos (double)  
• sin : double sin (double)  
• tan : double tan (double)  
• sqrt : double sqrt (double)  
• log : double log (double)  
• log10 : double log10 (double)  
• exp : double exp (double)  
• pow : double pow (double)  
• cosh : double cosh (double)  
• sinh : double sinh (double) 
• tanh : double tanh (double) 
• strcat : void strcat (char *str1, char *str2) 
• strcmp : int strcmp (char *str1, char *str2)  
• strcpy : void strcpy (char *str1, char *str2) 
• strlen : int strlen (char *str1) 
• strncat : int strcat (char *str1, char *str2, int) 
• strncmp : int strncmp (char *str1, char *str2, int) 
• strncpy : void strncpy (char *str1, char *str2, int) 

 
The following functions call sprintf(buf, str, data) internally.  

• sPrintl : void sPrintl( char *buf, char *str, int data)  
• sPrintF : void sPrintl( char *buf, char *str, double data)  
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(1) Coordinate system setting functions  

1. Set LDC/WC  

[Call] 
void g8_LdcWc (int mod) 

[Input] 
mod : 0=LDC, 1=WC 

[Output] 
None  

[Description] 
This is used to set LDC or WC coordinate system.  
 

2. Set clip area  

[Call]  
void g8_cliparea (int left, int top, int right, int bottom)  

[Input]  
left: Clip area left coordinate  
top: Clip area top coordinate  
right: Clip area right coordinate  
bottom:  Clip area bottom coordinate  

[Output]  
None  

[Description]  
This is used to set the clip to (left, top)-(right, bottom).  

 
3. Set clip on/off  

[Call] 
void g8_clip_on (int sw)  

[Input]  
sw : 0=clip OFF; 1=clip ON  

[Output]  
None  

[Description]  
When the clip has been set to ON, the area designated by the set clip area 
function is clipped. 
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(2) 8-bitVRAM graphics functions  

1. Clear all planes  

[Call]  
void g8_allclr (int col, int mod)  

[Input]  
col : color (0 to 255)  
mod : 1=set; 2=or set; 3=and set  

[Output]  
None  

[Description]  
This is used to clear or set all the graphic planes in the designated color.  

 
2. Clear screen  

[Call]  
void g8_clr (int col, int mod)  

[Input]  
col : color (0 to 255)  
mod : 1=set; 2=or set; 3=and set  

[Output]  
None  

[Description]  
When the clip has been set to ON, this function is used to clear or set the clip 
size screen from org [2] in the designated color; when it has been set to OFF, it 
is used to clear or set all the graphic planes in the designated color.  

 
3. Draw dots  

[Call]  
void g8_pset (int x, int y, int col, int mod)  

[Input]  
x : x coordinate  
y : y coordinate  
col : color (0 to 255)  
mod : 1=set; 2=or set; 3=and set  

[Output]  
None  

[Description]  
This is used to draw a dot at the designated coordinates. 
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4. Draw lines  

[Call]  
void g8_line (int xs, int ys, int xe, int ye, int col, int mod )  

[Input]  
xs : start point x coordinate  
ys : start point y coordinate  
xe : end point x coordinate  
ye : end point y coordinate  
mod : 1=set; 2 =or set; 3=and set  

[Output]  
None  

[Description]  
This is used to draw a line from the start point to end point. 
 

5. Draw squares (or rectangles)  

[Call]  
void g8_sqre (int xs, int ys, int xe, int ye, int col, int mod)  

[Input]  
xs : start point x coordinate  
ys : start point y coordinate  
xe : end point x coordinate  
ye : end point y coordinate  
col : color (0 to 255)  
mod : 1=set; 2=or set; 3=and set  

[Output]  
None  

[Description]  
This is used to draw a square (or rectangle) whose apexes are the start and end 
points.  

 
6. Draw and fill squares (or rectangles)  

[Call]  
void g8_sqpa (int xs, int ys, int xe, int ye, int col, int mod)  

[Input]  
xs : start point x coordinate  
ys : start point y coordinate  
xe : end point x coordinate  
ye : end point y coordinate  
col : color (0 to 255)  
mod : 1=set; 2=or set; 3=and set  

[Output]  
None  

[Description]  
This is used to draw and fill a square (or rectangle) whose apexes are the start 
and end points. 
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7. Draw and fill triangles  

[Call] 
void g8_tripa (int x1, int y1 , int x2, int y2, int x3, int y3, int col, int mod)  

[Input]  
x1 : x coordinate  
y1 : y coordinate  
x2 : x coordinate  
y2 : y coordinate  
x3 : x coordinate  
y3 : y coordinate  
col : color (0 to 255)  
mod : 1=set; 2=or set; 3=and set  

[Output]  
None  

[Description]  
This is used to draw and fill a triangle whose apexes are the designated three 
points.  
 

8. Draw circles  

[Call]  
void g8_crcl (int xc, int yc, int r, int col, int mod)  

[Input]  
xc : center x coordinate  
yc : center y coordinate  
r : radius  
col : color (0 to 255)  
mod : 1=set; 2=or set; 3=and set  

[Output]  
None  

[Description]  
This is used to draw a circle whose center is (xc, yc) and whose radius is r.  
 

9. Draw and fill circles  

[Call]  
void g8_crclpa (int xc, int yc, int r, int col, int mod)  

[Input]  
xc : center x coordinate  
yc : center y coordinate  
r : radius  
col : color (0 to 255)  
mod : 1=set; 2=or set; 3=and set  

[Output]  
None  

[Description]  
This is used to draw and fill a circle whose center is (xc, yc) and whose radius is 
r. 
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10. Draw ellipses  

[Call]  
void g8_elps (int xc, int yc, int rh, int rv, int col, int mod)  

[Input]  
xc : center x coordinate  
yc : center y coordinate  
rh : x radius  
rv : y radius 
col : color (0 to 255)  
mod : 1=set; 2=or set; 3=and set)  

[Output]  
None  

[Description]  
This is used to draw an ellipse whose center is (xc, yc) and whose radii are (rh, 
rv).  
 

11. Draw and fill ellipses  

[Call]  
void g8_elpspa (int xc, int yc, int rh, int rv, int col, int mod)  

[Input]  
xc : center x coordinate  
yc : center y coordinate  
rh : x radius  
rv : y radius 
col : color (0 to 255)  
mod : 1=set; 2=or set; 3=and set  

[Output]  
None  

[Description]  
This is used to draw and fill an ellipse whose center is (xc, yc) and whose radii 
are (rh, rv).  

 
12. Draw ellipses  

[Call]  
void g8_elps2 (int x1, int y1, int x2, int y2, int col, int mod) 

[Input]  
x1 : x coordinate  
y1 : y coordinate  
x2 : x coordinate  
y2 : y coordinate  
col : color (0 to 255)  
mod : 1=set; 2=or set; 3=and set ,  

[Output]  
None  

[Description]  
This is used to draw an ellipse which inscribes a square (or rectangle) of (x1, 
y1)-(x2, y2).  
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13.  Draw and fill ellipses  

[Call]  
void g8_elpspa2 (int x1 , int y1 , int x2, int y2, int col, int mod)  

[Input]  
x1 : x coordinate  
y1 : y coordinate  
x2 : x coordinate  
y2 : y coordinate  
col : color (0 to 255)  
mod : 1=set; 2=or set; 3=and set  

[Output]  
None  

[Description]  
This is used to draw and fill an ellipse which inscribes a square (or rectangle) of 
(x1, y1 )-(x2, y2).  
 

14. Copy area 2 (copy in graphics plane)  

[Call]  
void g8_bitblt2 (int src_x, int src_y, int x_len, int y_len, int dst_x, int dst_y, int 
mod, int inv, int mirr)  

[Input]  
src_x : transfer source start point (top left) x coordinate  
src_y : transfer source start point (top left) y coordinate  
x len : number of x dots  
y_len : number of y lines  
dst_x : transfer destination start point (top left) x coordinate  
dst_y : transfer destination start point (top left) y coordinate  
mod : 1=set; 2=or set  
inv : 0=normal; 1=inverted  
mirr : mirror  

0=no mirror; 1=left/right mirror  
2=top/bottom mirror; 3=top/bottom/left/right mirror  

[Output]  
None  

[Description]  
This is used to copy a square (or rectangle) area whose start (top left) point is  
(src_x, src_y) and whose size is (x_len, y_len) to an area whose start (top left) 
point is (dst_x, dst_y). 
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15. Draw characters  

[Call]  
void g8_putc (int fnt, int x, int y, unsigned char cod, int rop, int col, int bkcol)  

[Input]  
fnt : font No. (0=5x7, 1=7x9, 2=16x16)  
x : start point (top left) x coordinate  
y : start point (top left) y coordinate  
cod : character (0x20 to 0xdf)  
rop : 1=drawn in foreground; 2=drawn in background;  

3=drawn in foreground/background  
col : character foreground color  
bkcol : character background color  

[Output]  
None  

[Description]  
This is used to draw the designated character in the designated font with (x, y) as 
its top left point.  
 

16. Draw character string  

[Call]  
void g8_puts (int fnt, int x, int y, unsigned char *str, int h_pitch, int v_pitch, int 
rop, int col, int bkcol, int pos)  

[Input]  
fnt : font No. (0=5x7, 1=7x9, 2=16xl6)  
x : start point (top left) x coordinate  
y : start point (top left) y coordinate  
str : character string (terminated by null)  
h_pitch : horizontal direction character interval  
v_pitch : vertical/horizontal direction line interval  
rop : 1=drawn in foreground; 2=drawn in background; 

3=drawn in foreground/background  
col : character foreground color  
bkcol : character background color  
pos : 0=left-justified; 1=right-justified  

[Output]  
None  

[Description]  
This is used to draw the designated character string in the designated font with 
(x, y) as its top left point. 
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(3) LUT setting functions  

1. Set LUT color  

[Call]  
void opt_setcolor (int no, int r, int g, int b) 

[Input]  
no : LUT number (0 to 255)  
r : r (0-255)  
g : g (0-255)  
b : b (0-255)  

[Output]  
None  

[Description]  
This is used to set the output colors. 
The col drawing values (0 to 255) correspond to the LUT numbers (0 to 255). 
 

2.  Set LUT color (white linear)  

[Call]  
void opt_setcolor_liner ( )  

[Input]  
None  

[Output]  
None  

[Description]  
This is used to set the output colors of the VRAM to white linear (256 gradation 
of gray). 
 
#00H → r=0 g=0 b=0 

: : : : 
#ffH → r=ffH g=ffH b=ffH  
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3. Set LUT color (default)  

[Call]  
void opt_setcolor_default ( )  

[Input]  
None  

[Output]  
None  

[Description]  
This is used to set the LUT colors as follows:  
#00H-#07H : 0/255 times (#f8H--#ffH)  
#08H-#0fH : 8/255 times (#f8H--#ffH)  
#10H-#1fH : 16/255 times (#f8H--#ffH)  

: : : : 
#f0H-#f7H : 240/255 times (#f8H-#ffH)  
#f8H → r=00H g=00H b=00H 
#f9H → r=ffH g=00H b=00H  
#faH → r=00H g=ffH b=00H 
#tbH → r=ffH g=ffH b=00H 
#fcH → r=00H g=00H b=ffH 
#fdH→ r=00H g=ffH b=ffH 
#feH → r=ffH g=00H b=ffH  
#ffH → r=ffH g=ffH b=ffH   
 

4. Set LUT color (256 colors)  

[Call]  
void opt_setcolor_256 (unsigned char & col)  

[Input]  
col :col [768] is provided. (x256 in order of R/G/B)  

[Output]  
None  

[Description]  
This is used to set the LUT colors as follows.  
col [0]=R, col [1]=G, col [2]=B →  palette #0  
col [3]=R, col [4]=G, col [5]=B →  palette #1 

: 
: 
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5. Set window color  

[Call]  
void opt_setwndcolor (int no, int r, int g, int b) 

[Input]  
no : window number (0 only)  
r : R (0 to 255)  
g : G (0 to 255)  
b : B (0 to 255)  

[Output]  
None  

[Description]  
This is used to set the window color (R/G/B). Only #0 (1 color) can be 
designated for the window. (See window setting functions)  

 
(4) Display-related functions  

1. Inquire display size  

[Call]  
int vs_InqDispSize ( )  

[Input]  
None  

[Output]  
Return value : Higher 16 bits=number of vertical display lines  

Lower 16 bits=number of horizontal display dots  

[Description]  
This is used to return the horizontal/vertical display size.  
 

2. Inquire status  

[Call]  
int vs_InqStat (int type)  

[Input]  
type : type of inquiry  
0=inquire about currently selected dot clock  

[Output]  
Return value : When type=0  
DotClock : 1000 times xxx.xxx MHz (in other words, kHz units) 
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(5) Window setting functions  

1. Initialize window  

[Call]  
void vs_InitWindow ( )  

[Input]  
None  

[Output]  
None  

[Description]  
This is used to initialize the window line memory. The window is set using the 
vs_AddWindow ( ) function that follows.  
 

2. Set window data  

[Call]  
void vs_AddWindow (int wnd_no, int hs, int he, int vs, int ve)  

[Input]  
wnd_no : window number (0 only), 3 = clear  
hs : window position/horizontal start position  
he : window position/horizontal end position  

• Relative position within display period  
vs : window position/vertical start position  
ve : window position/vertical end position  

• Relative position within display period  

[Output]  
None  

[Description]  
This is used to set the window (it is set in the window register). Only 0 (1 color) 
can be designated for the window. (See opt_setwndcolor ( ))  
The rectangular portion which is set in the horizontal and vertical directions 
appears as the window.  
 
 
 
 
 
 
 
 
 
 
 
 
 

0 : window color #0 
The window can be initialized by vs_InitWindow ( ) and set by 
vs_AddWindow ( ). 

Horizontal hs he 

vs 

ve 

Vertical 

0000000
0000000
0000000 
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(6) Pattern drawing functions  

l. Draw character pattern  

[Call]  
void ptn_char (int fomt, int font, int code, int hcell, int vcell, int col, int rop,  
int bkcol, int area, int x1 , int y1 , int x2, int y2)  

[Input]  
fomt : character format (0=list; 1=character; 2=corner & center)  

(9=corner only)  
font : font (0=5x7; 1=7x9; 2=16xl6)  
code : code (20H to ffH)  
hcell : H cell size (1 to 255)  
vcell : V cell size (1 to 255)  
col : character foreground color (palette no: 0 to 255)  
rop : 1=drawn in foreground; 2=drawn in background; 

3=drawn in foreground/background  
bkcol : character background color (palette no: 0 to 255)  
area : 0 = entire display area; 1 = designated area  
x1, y1, x2, y2 : coordinates (LDC or WC); ignored when entire display area is 

designated.  
The pattern is drawn inside the (x1,y1)-(x2-y2) rectangle when the area is 
designated.  

[Output]  
None  

[Description]  
This is used to draw character patterns.  
 

2. Draw crosshatch pattern 

[Call]  
void ptn_cross (int mod, int fomt, int h_interval, int v_interval, int h_width,  
int v_width int col, int area, int x1, int y1, int x2, int y2)  

[Input]  
mod : mode (0=number of lines; 1=dots)  
fomt : format (0=from center; 1=from top left)  
h_interval : H interval (0 to 9999 lines, 0 to 9999 dots)  
v_interval : V interval (0 to 9999 lines, 0 to 9999 dots)  
h_width : H line width (1 to 15)  
v_width : V Iine width (1 to 15)  
col : drawing color (palette no: 0 to 255)  
area : 0=entire display area; 1=designated area  
x1,y1,x2,y2 : coordinates (LDC or WC; ignored when entire display area is 

designated.  
The pattern is drawn inside the (x1, y1)-(x2-y2) rectangle when the area is 
designated.  

[Output]  
None  

[Description]  
This is used to draw crosshatch patterns. 
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3. Draw dot pattern  

[Call]  
void ptn_dot (int mod, int fomt,int h_interval, int v_interval, int size, int type,  
int col, int area, int x1 , int y1, int x2, int y2)  

[Input]  
mod :mode (0=number of lines; 1=dots)  
fomt : format (0=from center; 1=from top left)  
h_interval : H interval (0 to 9999 lines, 0 to 9999 dots)  
v_interval : V interval (0 to 9999 lines, 0 to 9999 dots)  
size : size (1 to 15)  
type : shape (0=round; 1=angular)  
col : drawing color (palette no: 0 to 255)  
area : 0=entire display area; 1=designated area  
x1, y1, x2, y2 : coordinates (LDC or WC); ignored when entire display area is 

designated.  
The pattern is drawn inside the (x1, y1)-(x2-y2) rectangle when the area is 
designated.  

[Output]  
None  

[Description]  
This is used to draw dot patterns in the VRAM.  
 

4. Draw cross-shaped pattern  

[Call]  
void ptn_juuji (int col, int width_h, int width_v, int h_len, int v_len)  

[Input]  
col : drawing color (palette no: 0 to 255)  
width_h : horizontal line width (0 to 255) of center mark; 0 is treated as 1 .  
width_v : vertical line width (0 to 255) of center mark; 0 is treated as 1 .  
h_len : horizontal length (0% to 100%) of center mark; 0% is treated as 5%.  
v_len : vertical length (0% to 100%) of center mark; 0% is treated as 5%.  

[Output]  
None  

[Description]  
This is used to draw (cross-shaped) center mark patterns in the VRAM.  
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5. Draw frame pattern  

[Call]  
void ptn_waku (int col, int width_h, int width_v)  

[Input]  
col : drawing color (palette no: 0 to 255)  
width_h : horizontal line width (0 to 255) of edge mark; 0 is treated as 1.  
width_v : vertical line width (0 to 255) of edge mark; 0 is treated as 1.  

[Output]  
None  

[Description]  
This is used to draw edge patterns in the VRAM. 
 

6. Draw block pattern  

[Call]  
void ptn_block (int mod, int dir, int col_su, int h_interva[, int v_interval,  
unsigned char & col, int area, int x1, int y1, int x2, int y2)  

[Input]  
mod : 0=%; 1=dots; 2=lines  

0xH*col [ ] designation; data of up to Col [ ] used.  
8xH*col [ ] no designation; up to Col [0] = first palette No.; Col 
[1]=last palette No.; Col [2]=palette No. increment  

dir : direction (0=horizontal; 1=vertical; 2=horizontal & V;  
3=vertical & H; 4=top left→bottom right; 5=bottom left→top right; 
6=top right→bottom left; 7=bottom right→top left)  

col_su : number of palette No. data (1 to 256)  
h_interval : H interval (0.0 to 100%, 0 to 9999 dots, 0 to 9999 lines)  
v_interval : V interval (0.0 to 100%, O to 9999 dots, O to 9999 lines)  
col [256] : palette No. (1bytex Col_su) *max. 256  
area : 0=entire display area; 1=designated area  
x1, y1, x2, y2 : coordinates (LDC or WC);  

ignored when entire display area is designated  
The pattern is drawn inside the (x1, y1)-(x2-y2) rectangle when the area is 
designated.  

[Output]  
None  

[Description]  
This is used to draw block patterns in the VRAM.  
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7. Draw burst pattern  

[Call]  
void ptn_burst (int fomt, int interval, int step, int col1, int widthl, int col2,  
int width2, int area, int x1, int y1, int x2, int y2)  

[Input]  
fomt : format (0=left→right; 1=right→left;2=center→left/right;  

3=left/right→center; 4=top→bottom; 5=bottom→top; 
6=center→top/bottom; 7=top/bottom→center)  

interval : interval (1 to 99): number of lines of same thickness  
step : step (1 to 99): thickness increments  
coll : #1 drawing color (palette No.: 0 to 255)  
width1 : #1 line width (0 to 255)  
col2 : #2 drawing color (palette No.: 0 to 255)  
width2 : #2 line width (0 to 255)  
area : 0=entire display area; 1=designated area  
x1,y1,x2,y2 : coordinates (LDC or WC);  

ignored when entire display area is designated  
The pattern is drawn inside the (xl, yl)-(x2-y2) rectangle when the area is 
designated.  

[Output]  
None  

[Description]  
This is used to draw burst patterns in the VRAM. 
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CHAPTER 6 
ERROR REFERENCE  

The various error messages which may be displayed by the SP-8022 are listed below. 

Error message Code 
(H) Description 

Parameter Error  0101 Parameter error 

DotClock Range Error  0110 Dotclock in the horizontal timing data is outside the 
specified range. 

Hfrontp Range Error  0111 The front porch in the horizontal timing data is 
outside the specified range. 

HD (start+Width) Range Error  0112 HD in the horizontal timing data is outside the 
specified range. 

Hperiod Range Error  0113 Hperiod in the horizontal timing data is outside the 
specified range. 

Hdisp Range Error  0114 Hdisp in the horizontal timing data is outside the 
specified range. 

Hsync Range Error  0115 Hsync in the horizontal timing data is outside the 
specified range. 

Hbackp Range Error  0116 Hbackp in the horizontal timing data is outside the 
specified range. 

Hblanking Range Error  0117 The blanking period in the horizontal timing data is 
outside the specified range. 

Hfreq Range Error  0118 The horizontal frequency in the horizontal timing 
data is outside the specified range. 

Other H-Timing Data Error  0119 Other error in the horizontal timing data. 

Vtotal Range Error  0120 Vtotal in the vertical timing data is outside the 
specified range. 

Vdisp Range Error  0121 Vdisp in the vertical timing data is outside the 
specified range. 

Vsync Range Error  0122 Vsync in the vertical timing data is outside the 
specified range. 

Vbackp Range Error  0123 Vbackp in the vertical timing data is outside the 
specified range. 

Vfrontp Range Error  0124 The front porch in the vertical timing data is outside 
the specified range. 

Vblanking Range Error  0125 The blanking period in the vertical timing data is 
outside the specified range. 

Vfreq Range Error  0126 The vertical frequency in the vertical timing data is 
outside the specified range. 

VD Start+Width) Range Error  0127 VD in the vertical timing data is outside the specified 
range. 

Veqpfp Range Error  0128 EQPfp in the vertical timing data is outside the 
specified range. 

Veqpbq Range Error  0129 EQPbp in the vertical timing data is outside the 
specified range. 

Other V-Timing Data Error  012A Other error in the vertical timing data. 
Timing Data Disable  0130 Timing data disable error. 
Pattern Data Disable  0131 Pattern data disable error. 
FlashMemory write Error  0140 Flash card writing error. 
User Character Code Error  0141 User character code is outside the specified range. 
User Character Size Error  0142 User character size is outside the specified ranae. 
Timing NO Error  0143 Timing number is outside the specified range. 
Palette NO Error  0144 Palette number is outside the specified range. 
FontSet NO Error  0145 Font number is outside the specified range. 
FontSet FAT Error  0146 Font data call error. 
FontSet Data Not Regist  0147 Font data error. 
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Error message Code 
(H) Description 

Pattern NO Error  0148 Pattern is not registered. 
Pattern Data Size Over  0149 Pattern data size is outside the specified range. 
Pattern Data Not Regist  014A Pattern data error. 
Pattern FAT Error  014B Pattern data call error. 
Pattern Data Size Over 014C Pattern data size is outside the specified range. 
Flash Firm Disable  0150 Flash card disable error. 
Flash Firm Write Error 0151 Flash card writing error.  
Write Flash while Firm Working 0152 Flash card writing error. 
Communication TimeOut 01F0 Communication timeout error. 
Undefined Command 01F1 Undefined command error. 
V-Sync Timeout 01F2 V-sync timeout error.  
 
The various error messages which may be displayed when optional patterns are created are listed 
below. 

Error message Code 
(H) Description 

Program not Exist 0201 Program has not been loaded. 

Variables Stack Error 0202

Variable stack error. (Overflow or underflow) 
An overflow may occur when the number of 
hierarchical levels increases for the functions that 
have declared many variables. 

Register Stack Error 0203
Register stack error. (Overflow or underflow) 
An overflow may occur when the calculation formula 
is too complex. 

Call Stack Error  0204
Function call stack error. (Overflow or underflow) An 
overflow occurs when the number of function call 
hierarchical levels exceeds 64. 

Illegal Instruction Code 0205
An attempt was made to execute an illegal 
command. The compiled program may have been 
destroyed. 

Divide by Zero 0206 Division by zero was executed. 
Math Error 0207 Mathematical error 

Unfinished Error 0214
The program was terminated part of the way 
through. This may occur if the parentheses { } are 
not paired up properly. 

Program Size too Big 0215 The program size is too big. 
Variables Area Overflow 0216 The variable area has overflowed. 
Illegal Character 0217 An illegal character has appeared. 
Numeral Buffer Overflow 0218 A character string expressing a number is too long. 

String Buffer Overflow 0219 The character string has more than the maximum 
255 characters. 

malloc Fail 021A Insufficient memory. 
No Semicolon 021B The statement does not end with a semicolon. 
Variable Not Defined 021C An undefined variable was used. 
Illegal Expression 021D The type of expression is not correct. 

Illegal Expression for Real 021E
The type of expression using real numbers is not 
correct. This occurs when a bit inversion operation is 
performed for a real number. 

Unbalanced Parenthesis ( ) 021F The parentheses ( ) are not paired up properly. 
Unbalanced Bracket [ ] 0220 The brackets [ ] are not paired up properly. 

Symbol Solve Error 0221
The correspondence between the symbol (variable 
name or function name) definition and reference is 
illegal. 

Multiple Symbol Definition 0222 The same symbol has been defined more than once.
'main()' Definition Error 0223 "main" function definition error. 
'goto' Statement Error 0224 "goto" statement error. 
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Error message Code 
(H) Description 

'return' Statement Error 0225 "return" statement error. 
Return Type error 0226 The type of function return value is illegal. 
'if' Statement Error 0227 "if" statement error. 
'while' Statement Error 0228 "while" statement error. 
'do' Statement Error 0229 "do" statement error. 
'for' Statement Error 022A "for" statement error. 
'switch' Statement Error 022B "switch" statement error. 
'case' Statement Error 022C "case" of statement error. 

Too Many 'case' Statement  022D Too many "case" statements have been used. Up to 
127 "case" statements can be used per "switch". 

'default' Statement Error 022E "default" statement error. 
'break' Statement Error 022F "break" statement error. 
"continue" statement error 0230 "continue" statement error. 
Argument Type Error 0231 Illegal type of function argument. 
Number of Argument Error 0232 Illegal number of function arguments. 
Function Call Error 0233 Illegal function call. 
Function Declare Error 0234 Illegal function declaration. 
Variable Declare Error 0235 Illegal variable declaration. 
Argument Declare Error 0236 Illegal function argument declaration 
Variable Initialize Error 0237 Illegal variable initialization. 
Array Declare Error 0238 Illegal array variable declaration. 
Mode Error (Write or Not) 0264 Illegal object control mode. 
Code Poke Offset Error 0265 Error in offset during code writing. 
Parser Error  0266 Parsing status error. 
Expression Error 0267 Numerical expression analysis status error. 
Build-In Function Error 0268 Built-in function error. 
User Function Error 0269 User-defined function error. 
Internal Label Error 0270 Label control error in parsing. 
 
The various error messages which may be displayed from the driver are listed below 

Error message Code 
(H) Description 

Driver: Command Execution 
Timeout. 0840 Driver: Command execution timeout. 

Driver: Command Parameter Error. 0841 Driver: Parameter Error 
Driver: Control Port Not Ready  0842 Driver: Data cannot be written into control port. 
Driver: Data Port Write Timeout. 0850 Timeout for writing data into data port. 
Driver: Data Port Read Timeout. 0851 Timeout for reading data from data port. 
Driver: DMA Timeout  0860 DMA execution timeout. 
Driver: DMA Illegal Page 0861 DMA memory error.  
Driver: DMA Linear Lock 0862 DMA memory lock error.  
Driver: DMA CopyPageTable 0863 DMA memory page processing error. 
Driver: DMA Setup 0864 DMA setup error.  
Driver: DMA Start Read 0865 DMA start error.  
Driver: DMA Start Complete 0866 DMA start completion error.  
Driver: DMA Trans Complete 0867 DMA transfer completion error. 
Driver: Wait Interrupt Timeout 0870 DMA transfer completion wait error. 
Driver: Parameter Error 087D Parameter error. 
Driver: Device IOControl Error 087E Driver call error. 
Driver: Device Open Error 087F Driver open error. 
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The various error messages which may be displayed when the created optional patterns are executed 
are listed below. 

Error message Code
(H) Description 

Option Pattern not exists  0081 User-created optional pattern does not exist. 
Variables stack error 0082 Variable stack error. 
Register stack error 0083 Register stack error. 
Call stack error. 0084 Function stack error. 
Illegal instruction 0085 Illegal instruction code. 
Divide by Zero 0086 Division by zero was executed. 
Math error 0087 Error in floating decimal point calculation.  
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NOTICE 
 
• An incorrectly collated manual or a manual with missing pages will be replaced.  

• All copyrights pertaining to this product are the property of ASTRODESIGN.  

• This manual may not be copied in whole or in part without written permission.  

• The contents of this manual are subject to change without prior notice due to 
improvements.  

• The manufacturer will not be liable for any effects caused by the faulty operation of 
this product.  

• All inquiries concerning this product should be addressed to your dealer or to the 
manufacturer at the contact numbers given below 

• The products and product names mentioned in this manual are the trademarks of 
the companies concerned.  
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